Jump to content
Sign in to follow this  
mjfpx

EF-X500 TTL Not Syncing?

Recommended Posts

Hello Everybody,

I am new to the forum and unfortunately I have start out with a technical problem.

I have a EF-X500 flash unit and seemingly out of nowhere if I use TTL the flash will fire but I get nothing but black. If you put it on manual and multi it works as it should. I am not sure if it is some sort of sync issue or what. I get the same result when I have it on FP or Front or Rear Curtain. I usually don’t put the shutter above 125th anyway. I tried resetting all the settings on the flash. I am sort of stumped and the only thing I can think of is that it is just not syncing somehow.  

Anybody have any thought. 

Screen Shot 2019-06-01 at 11.19.25 AM.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...