Jump to content

X-T10 Parts or schematic source, quality issues?


Chris250
 Share

Recommended Posts

Advertisement (gone after registration)

Hi All,

I have an X-T10 that stopped dead last week seemingly out of the blue.  Went through all the basics...  battery charged, repeatedly trying off/on, connecting to Laptop via USB, W/wo lens, w/wo SD card...  no sign of life whatsoever.  Upon careful examination, I could hear something loose inside.  Removed the battery, SD card, and lens and capped it, and proceeded to disassemble it following a youtube video I found of somebody fixing a broken playback button.  Anyhow, with the bottom and back off, out rolls a maybe 7mm long silver screw.  I am an electrical engineer and tinkerer by trade, so I began tracing power and noted that the fuse on the main board was blown open, my guess being that screw crossed power supply components on the main board to blow it.  Still working through disassembling further to try to figure out where the loose screw belongs.  Jumpered out the fuse and see power rails come up on the main board, though not sure yet if there is other damage.  Anyhow, long background to a few questions:

  1. Have many others seen similar sudden deaths with their  X-series cameras?  I invested in a few lenses and hoped the body would go more than a few years without serious heartache.
  2. Does anyone know of a source for an electrical schematic, service manual,  or parts list for the X-T10.
  3. Does anyone know of a source for parts for out of warranty FujiFilm Cameras, other than looking for a broken donor body on Ebay?  I see some parts (circuit boards, components, etc) online shipping from China, but not sure of their original source or for the money if I'd trust them.

Addition 3 days later:  The loose screw was from up in the top securing the eyelet that the strap attaches to on the shutter side.  It must have shorted some components and done some damage while loose because even with the fuse replaced , the camera is not right.  Powers on with a blank screen, and after pushing buttons it seemingly randomly will come to a screen as if taking a picture, but solid white (even with lens cap on).  Can get into menus and change them, and can playback shots on the SD card, but cannot take a pciture or see anything but white.  Tried re-writing the firmware to it as a last ditch effort, with no improvement.  Thinking it's toast at a level beyond my repair capabilities at this point.   Sad to think that for a drop or two of thread lock on that screw at the factory, this failure could have been avoided.  

Final notes:  Found 2 other fuses  on the back side of the main board, and one was  also blown.  Replaced it (as well as the main one on the top side) and my camera is alive again!!

 

Edited by Chris250
added tags, updated info.
Link to post
Share on other sites

  • 1 year later...

Oh, pretty happy to have stumbled on your post. Thanks for posting.

My issue was that as soon as the camera lens attaches, the screen (also EVF) was blinking, switching on and off, after roughly 20s LCD displays "Lens Error". None of the simple and usual fixes did not help, like cleaning contacts, or rewriting the firmware.

When started dissassembling the camera, one long screw fell out. I think it was exactly the same like yours. The one holding an metal piece for a strap next to a shutter button. It must have shorted something too.

Now I need to somehow find what exactly got shorted :)

Edit:
I opened up and took out the main board. Nothing for my untrained eye looks damaged. But one of the fuses on the back size (Fuse has printed O symbol on it) has high resistance. Not like others which show resistance close to tester leads / cables. Does that mean that this fuse is blown?

Edit:
Replaced the blown fuse, screen is still flashing with lens attached, other 2 fuses does not appear to be blown.
All other usual methods like cleaning contacts, multiple lenses and so on are already tried.

Edited by rigu
top up later.
Link to post
Share on other sites

  • 8 months later...

Hi @Chris250 You are amazing.

I bought an XT-10 that was broken. Upon reading your post I reconized the issue. Excactly the same issue.

So I went and checked the fuses (and found a loose screw). Once I replaced the fuse it now totally works again.

Thank you so much for posting your issue and sollution.

 

Greetings from a now happy friend

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Similar Content

    • By X10_to_X70_to_XA3
      Bought my X-Pro 3 from B & H last November (2019). I haven't even taken it out from the house all this time, so no photo shoots. I rarely power it up. 
      Still on the 1st battery, but a couple weeks ago, I powered it on just to check the status, and it flashed low battery icon, then shut off by itself. 
      I plugged it in last night to charge (odd, that the charge light is green? Thought it would be red until completely charged). Today, the camera wont power on.
      I tried the trick where you remove the battery while the power switch is on, then put the battery back in, but no luck there. 
       
      Dead circuit board? How does a camera crap out when it is never used? 
      Does anyone have any suggestions, other than shipping it in? Do battery chargers work better than the USB cable route?  
       - Thanks.
  • Posts

    • I've tried a number of lens hoods, but they all have the disadvantage of not being able to fit the lens cap when not in use. This one is specifically designed to take the standard lens cap and even has a soft rubber ring to ensure a snug fit. Very nicely made in anodised aluminium. https://www.ebay.co.uk/itm/252370651839?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2060353.m2749.l2649 (not connected to seller)
    • Firmware 2.10. Newly formatted sd card. And yes, I've taken a few shots. Menu Set up - Save Data Set-Up - Select Folder - "Create New Folder" is grayed out. So I cannot create a new folder. I'd like to create folders so I can store images by date. Any thoughts on how I can fix this?
    • If I put my X-S10 on a table (or any other stable surface), focus on subject and set an exposure the will require more than 1 second of exposure (doesn't matter how many, just make sure that the desired exposure will be more than 1 second), set a timer for 2 seconds and take a shot and the IBIS is set to mode 2 (Shooting only), the shot comes out completely blurry, just like if I hand held the camera (which I didn't). I repeat the EXACT same steps but this time I set IBIS to mode 1 (Continuous) - shot is tack sharp. Why? I know that IBIS should be disabled if the camera is on a tripod or any other stable surface, my question is why this happens only in mode 2 and not in mode 1 as well?
    • Ah a flick of the 'Auto' lever has fixed it! Why do they have to make things so obscure! If it said in the manual 'ES not available in Auto mode' that would have made life so much easier! Anyway, thanks for your help @Greybeard!
×
×
  • Create New...