Jump to content
Bigmack8

SD Card Transfer Problem

Recommended Posts

hi,

I just shot a wedding yesterday with my x-t3 and used a Lexar Professional 1000x 128GB SDXC UHS-II Card. When I went to transfer the footage neither my Mac or any SD card reader I use allowed me to access the SD card. 

The card functions and plays back the footage via the camera but I have no idea how to get it off. Can someone please advise?

I tried attaching the usb cable to my camera & Mac to see if I could transfer it that way but my Mac didn’t show the camera in the finder. It only shows as a device when I open Apple Photos but when I try to import the footage I only get about 3mins for each clip even though all the clips are a lot longer than that.

Share this post


Link to post
Share on other sites

I just happened to have the same problem two days ago with my iMac. I could see my images in my two cameras: a Nikon D750 and Fujifilm XT-3. Never had a problem before. I ended up getting an Insignia USB-SD card reader. I used it for the last two days to import my images into Lightroom with no problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...