Jump to content
Sign in to follow this  
joust1154

XT1 LCD shutting off when articulated downwards

Recommended Posts

Hi, so I shoot mostly using the LCD, from the hip, and I encountered a program today with my XT1's. Somewhat similar to an old post: https://www.fuji-x-forum.com/topic/1948-x-t1-lcd-fails-when-articulated/

 

But my situation is a little different. When my LCD is completely flush, in the normal position against the body, it will be totally blacked out/looking like it's off. I've cycled the 'viewmode' and nothing has helped. I did a factory reset and updated the firmware. But I believe I have a body-to-LCD ribbon short.

 

If I pull the LCD away it will work, but only in a limited range. From angled slightly upwards to completely flat facing upwards to the sky. If it's totally parallel with the body to facing downs toward the ground, the LCD will black out/turn off. I can still take photos when it's like this though. 

 

I'm pretty sure it's a short in the ribbon — if I push the ribbon around very gently, the screen will go on and off. But anyway, I would like to put this problem out there and see if anyone has encountered it before. The camera has seen a lot of use in the last 3 years, but no drops/damage. Luckily the EVF works normally and used XT1s are pretty cheap now. 

 

Let me know if you have any suggestions, thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×