Jump to content

X100f - Sticky Aperture Blades


Recommended Posts

  • 3 weeks later...

Hi all, X100F is back from repair (free under warranty)and working fine. Shutter count has been reset to zero, so I am guessing that the shutter mechanism has been replaced. All settings are back to factory defaults, so have had to restore all of my settings, but a small price to pay....happy camper again!

Link to post
Share on other sites

I have not heard of this problem and hope it does not happen to my X-100F which is working fine. Love that little camera!

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

Link to post
Share on other sites

It is very strange. Years ago I bought a x-100 . It was the only fuji camera with aps-c and very soon I have had the problem with aperture blades. X-100  was repaired and I yet have it. But I thougth that the problem  had been  solved with the new models S, T, F

Edited by bergat
Link to post
Share on other sites

  • 1 month later...

I, too, have been the unfortunate recepient of a defective X100F.  Had it for a week before I realized that my aperture blades had become stuck in a fixed position somewhere in the middle of the scale.  Googled the issue and was quickly able to diagnose why my outdoor photos were getting totally overexposed.  Called Fujifilm USA to see if they had a solution but the only recommended remedy was to return it to Adorama from where I had just purchased it. Frankly, I'm not too thrilled with the situation but I am getting a new one in exchange.  I'm hopeful that the replacement will be fine. I've already sold all of my Nikon SLR gear with multiple lenses and I have high hopes that the X100F will be a wonderful tool that will produce fabulous images.

 

 

Link to post
Share on other sites

  • 2 years later...

A few months ago my X100F  started showing signs of the sticking aperture blade problem. I noticed the problem when I was trying to shoot in video using Manual mode, the aperture wouldn't open or close. I usually shoot in AP mode but with closer inspection notice that it's stuck at about f2.8. In both manual or AP there is no movement in aperture when trying to open or close using the aperture ring and pressing shutter half way. I've tried resetting preferences and the firmware is updated but no luck. I bought the camera new 2 years ago in the US but I currently live in Asia. I contacted Fujifilm USA but they told me to contact the office in Malaysia. The office in Malaysia said that I should contact the office closer to my region which is Northern Asia. I looked at the Fujifilm Japan website but their repair offices are closed indefinitely.  I seriously loved this camera and always treated it extremely well. I don't understand why this problem occurred and how to get it fixed. From what I understand it'a quite an expensive repair. I read about $600. I'm extremely disappointed with Fujifilm and have had no luck with their repair or customer service.

Has anyone had success taking this camera apart to fix this problem. It doesn't look like I'm going to get any help from Fujifilm anytime soon. 
Any help or insight into repair would be greatly appreciated.

Edited by BRT
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...