Jump to content
Sign in to follow this  
richcaw

X-Pro 2 "turn off camera turn back on again"

Recommended Posts

Since upgrading to firmware version 3.10 my X-Pro 2 developed the cursed turn off camera turn back on issue. After searching, have tried resetting the various options allowed under the wrench tab in menu, removing batteries, with no success. 

 

The issue arises whether using my 10-24 or my 16, 35 and 56mm primes and in S,C and M modes and in single shot or lo/hi speed shooting drive modes.   

 

The camera successfully upgraded firmware to 3.11 and for one day this appeared to have fixed the problem but now it is back. The camera will take one image and error appears after taking  a second image. The first image writes to the card but not the second. 

 

Anyone else have a similar phenomenon? 

 

Guessing my favourite camera is headed back to Fuji.  

Share this post


Link to post
Share on other sites

I am seeing that message when I mount my single prime on my XPro2 body. Could be this message is generic and is saying that the body is sensing a lens change but cannot establish communication with the lens (?)

 

Sent from my Pixel XL using Tapatalk

Share this post


Link to post
Share on other sites

I used to have this problem with the borrowed 27. Turned out the culprit was the step-up ring attached on the lens. At first it worked okay for many shots then suddenly had that same error message. I was afraid that the camera had problem. After some browsing one post mentioned about possible use of step-up ring and/or filter. Once I took that off, no more problem.

Share this post


Link to post
Share on other sites

I just sent one of my three lenses to Fuji repair for that. I called the 800 number then had to wait 5-6 minutes till I talked to a repair rep. Probably SOP. Anyway he commented that that error meant that the focusing motor was not operating properly. I am just in the one year warranty period on all my Fuji so hopefully they'll fix it NC, we shall see.

 

Sent from my Pixel XL using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...