Jump to content
tpellicer

SD card is stuck in my XT1 - no movement

Recommended Posts

Advertisement (gone after registration)

Hi all, 

 

I hope someone out there can help me figure out how to get my SD card out of my XT1??? First, I'm not new, I've been using 2 XT1's for over a year. Yesterday I shot a big job for an Interior Designer and this morning when I went to copy the images the SD card will not come out. When I push on the card to eject it, there is NO movement, normally it pushes down a little then pops up. This card is stuck, no movement. I'm very nervous as I have a very important job on that card and can't risk looking any images.

 

Please can anyone advise me how to get the card out without damaging the card?

 

Thank you!

Share this post


Link to post
Share on other sites

Can't really suggest how to remove the card but you can use the Fujifilm PC Autosave software to wirelessly copy your images to a computer (http://www.fujifilm.com/support/digital_cameras/software/pc_autosave/mac/) or (http://www.fujifilm.com/support/digital_cameras/software/pc_autosave/win/). At least you'll have saved your work and can then sort out the camera later. 

Share this post


Link to post
Share on other sites

it is a known problem, cut a very thin piece of hard plastic or a piece from a playing card ( waxed) and then slide on the side of the contacts ( which are probably causing the card to catch), you should be able to remove it.

 

anyway there are other threads on the subject, as usual, things hardly ever happen to one person alone.

 

http://www.fuji-x-forum.com/topic/3467-card-slot/

Edited by milandro

Share this post


Link to post
Share on other sites

Advertisement (gone after registration)

it is a known problem, cut a very thin piece of hard plastic or a piece from a playing card ( waxed) and then slide on the side of the contacts ( which are probably causing the card to catch), you should be able to remove it.

 

anyway there are other threads on the subject, as usual, things hardly ever happen to one person alone.

 

http://www.fuji-x-forum.com/topic/3467-card-slot/

 

Thank you for your reply, I tried the playing card suggestion, but did not have any luck. I actually figured out you can use some tweezers made by Revlon sold at Target for $5 to grab the card out. Worked perfect and it did not damage my camera or SD Card. Phew.....

Share this post


Link to post
Share on other sites

Can't really suggest how to remove the card but you can use the Fujifilm PC Autosave software to wirelessly copy your images to a computer (http://www.fujifilm.com/support/digital_cameras/software/pc_autosave/mac/) or (http://www.fujifilm.com/support/digital_cameras/software/pc_autosave/win/). At least you'll have saved your work and can then sort out the camera later. 

Thank you so much I tried this option, but I shot RAW and JPEG and the communication was so slow it kept dropping. I think it would be fine if I was only transferring a few images, but I had 274 images.

Share this post


Link to post
Share on other sites

To save the images you might try connecting the camera to your computer via a USB cable and transferring the pictures that way!

 

NOT using the remote app I should add, if accomplished it will leave you free to give the obstinate SD card some wellie.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By waneijs
      I am planning to purchase the new FujiFilm XT-4 when it is available in NL. 
      With the launch of the XT-4 FujiFilm removed the supported SD Cards from the compatibility section on their website.
      The link is still present on the XT-3 specifications website but the link is not working anymore
      * 1 Please see the Fujifilm website to check memory card compatibility
      https://www.fujifilm.com/support/digital_cameras/compatibility/card/x/?_ga=2.36026537.881780981.1588514698-1422211324.1588514698  
      I am planning to shoot both video and stills, and I selected two SD cards of 128 GB SDXC V90 UHS-II on their specifications and price
      Lexar 128GB Professional 2000x UHS-II SDXC Memory Card
      https://www.amazon.com/Lexar-Professional-2000x-128GB-UHS-II/dp/B012PL522W?ref_=s9_apbd_simh_hd_bw_b51Uq&pf_rd_r=024ABYFTPNGFBZWMKNQV&pf_rd_p=4857e4ec-7a8c-5815-af71-33dcd2497338&pf_rd_s=merchandised-search-10&pf_rd_t=BROWSE&pf_rd_i=1197396  ProGrade Digital 128GB UHS-II SDXC Memory Card
      https://www.amazon.com/dp/B07T9JWPBJ/ref=emc_b_5_t?th=1 Does anyone have any experience with those SD cards?
      Is there any way I can verify with FujiFilm which 128 GB SDXC V90 UHS-II are supported or recommended by them?
      W.A. Neijs
    • By Marshall Timkii Hoang
      hi guy, I'm using X-h1, X-t1 with few lenses. I wonder should I buy an X100T or an extra 23mm f/2.0 lens. I'm gonna do street photography and sometime travel?
       
      Thank you guys. 
    • By silverhow
      I have an XT1 and absolutely love it. I'm thinking of trading it in for an XT3 - but am wondering if it is worth it. I'm not really interested in movies, and most of the extra you get with the XT3 seems to be in the video area. Also, is the XT3 heavier than the XT1? I really like the light weight of the XT1.
    • By traveltarte
      Recently my XT1 stopped working, when I have a lens attached the lcd screen flashes for 20 seconds and then I get the message "Lens Control Error" on screen and am unable to take any shots. I've tried a few things already (listed at the bottom) and none of these steps have resolved the issue. I've tested it with my 16mm lens and another lens and the error seems to occur with any lens, so I'm sure it's an issue with the body and not the lens. When I remove the lens the error doesn't occur.
      I'm currently travelling in Colombia and according to their designated service centre here (who I'm not entirely sure I trust) I need to have the camera's main board ("tarjeta principal") replaced, for which they're quoting around $150. I just want to be sure that this really is the issue before I shell out the cash to have it fixed.
      Has anyone had this error fixed by Fuji and if so, do you know what element needed to be fixed? 
      Thanks in advance.
      S
      Steps I've already tried:
      Turned the camera on and off; removed the battery for a few mins and replaced; updated the firmware for both the camera and lens; reset the camera to factory default settings; taken the lens on and off; cleaned the copper contact points both on the lens and the body.
       
    • By amirhoseinabedian
      Hello Guys

      My name is Amir, I'm a Photographer from Iran.
      I recently Joined this Community because I need your advice or opinion on a situation here.

      I'm a film shooter and recently I decided to buy a Fujifilm X Camera. I mainly do Landscapes, along with some portraits and street.

      I'm on a tight budget (roughly 1100$) and new Fuji products are very expensive here! (more than their normal price worldwide!) so I'm not in a good financial position to buy a Fuji X-T2...
      But recently I came across two options here. one is a brand new Fujifilm X-T1+18-55 kit lens around 800$ price tag (special offer) and the other one is a used X-T20+18-55 kit lens (roughly 2000 shots) around 950$.

      Depending on my needs, which one do you suggest? I'm planning to go with it for a minimum of 3 years so its a crucial choice for me here and also the weather sealing is a real deal breaker for me.

      what do you suggest? what should I do?
       
  • Posts

    • I have been using my XT4 quite a bit lately--mostly making outdoors videos, but also some family/portrait shoots.   One strange thing that I've noticed:  After setting up the display exactly how I like it, the EVF will display histogram, level, and battery level (among other things).  However, when I am just looking at the back screen, these 3 items are not displayed--UNLESS I turn off the AF!  As soon as AF is turned off, histogram, level, batt level appear on the rear screen exactly where
    • Fuji gave us the X-Pro3 for still focused users, no? Personally, I'd sacrifice AF for IBIS and if Fuji had more OIS lenses, sacrifice IBIS desires as OIS is close enough. Just too useful with environmental portraits. I have the GF45-100 primarily because of OIS.   
    • Hi all, This is my first Fuji camera and I couldn't be more excited to receive my Silver X-T4 with 16-80mm Lens Kit. As most know, the date keeps getting pushed on this kit. Originally it was May, then it was June 1st, and now, the status on BH Photo is now changed to "Backordered" as of yesterday. I reached out to B&H this morning to get some sort of update and all I received was "Unfortunately we don't have an expected delivery date at this time for your order as it is currently backo
    • I've got the same problem. The XT3 works well with ronin sc when it's connected with usb-c cable. But not the XT-4 !! we must all have to write at Fujifilm and DJI asking them to update their firmware!
×
×
  • Create New...