Jump to content

xt1 Focus Lock on Half-Pressed Shutter for multiple shots needed


sermiranda

Recommended Posts

Hi guys, I'm new in the forum. Have had an x100s for almost 4 years and I always loved it. It has always been my travel camera. But I always found a limitation to it and I thought bigger and more professional Fuji cameras wouldn't have it.

 

For my professional work (fashion/advertising/food photography) I was using a nikon D800e (always been a nikon photographer, until my x100s made me think about it).

 

Recently, I traded my nikon gear (body and three lenses) for a Fuji xt1 gear with a friend (two bodies, three lenses).

 

NOW, I find something majorly dissapointing:

 

I need the shutter button to hold a focus lock when kept half pressed after the first shot.

 

further explanation? I focus on a subject with a half press of the shutter (most cameras in the world will give you a beep sound to check that focus was acquired, something else I'm missing in the Fuji) and then I either recompose or just stay with the same framing, but I continue pressing the shutter many times to get many shots, always lifting my finger enough for the new shot, but not so far to unpress completely. So I keep the Half-press and the focus stays locked in the first setting (the first time I pressed)...

 

Xt1 fails to do this and the only solution I've found so far is to use the Back Button AF-L. This could work, but why use two buttons when it could be just one (and it could have a beep for focus acquisition). Does this bother anyone else?

 

Also, lastly, anyone knows if the xt2 or the xpro2 behave the same way? According to this video xpro2 has a system like I want, but can someone confirm this? Cause if its like this, I'm switching one xt1 to the xpro2.  Xt2 maybe too?

 

Thanks guys, and I really hope this could appear in the future in firmware updates.

 

All the best to all

 

Sergio Miranda

 

www.sermiranda.com

Link to post
Share on other sites

With the X-T1 in auto focus mode you can  set the AEL button to On/Off switch. This way you press the ael button once and it locks your current focus. You can release the button and the focus stays locked. Then take as many pictures as you want.

OR

In manual focus mode use the ael button to lock focus. Press it and camera focusses focus locks. Then take as many pictures as you want. 

Link to post
Share on other sites

  • 5 months later...

Like what cprevost said, it's better to decouple the AF from the shutter trigger. That is also how it can be done on other brands cameras, e.g. my old Canon could do the same trick.

Depending on what apertures you use, the focus & recompose method may not give the best results. Especially with the 56/1.2 @ 1.2 just a slight movement already causes a big shift in what is in focus. I have tried to learn myself to move the focus points around instead, or use the face detection feature. When it works, it is a very nice feat.

Link to post
Share on other sites

  • 6 months later...

Hi my name is Des from the UK new to this forum. Thank you for answering the question on locking focus on a XT1 it was a question I needed to ask as I was a little confused. I am just an amateur. Photography is a hobby and hopefully I shall enjoy my new hobby and undoubtedly pick up some good tips from this forum.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

  • Posts

    • Hello, it worked!! thanks for your help
    • I don't know whether I've missed something along the way, but here's my view: Firstly, I'm new to the digital world, having used film all the way (still using film as well as plates on occasion). I've always used prime lenses, with zooms being something  of a reluctant inclusion to my armoury. I'm still using the old glass a bit on my X-T5. However, I've found to my surprise that the kit lens, for a start, (the 16-80mm f4) is actually very good. I've also got the 55 - 200mm and the 35mm prime (this being my "nifty fifty". I'm happy with the coverage and happy with the IQ from them all at the middle aperture ranges which I use so much. Time was when I wouldn't have given a zoom much consideration at all, but these lenses aren't letting me down in any way. In fact, I was seriously impressed for once to find a kit lens which was a "keeper" (weather-resistance included!). If someone was starting out, they could get by very easily with that on its own for quite some time, without feeling the need to replace it soon after purchase. I only actually got the kit lens because I had nothing which would speak to the camera, and I wanted the camera to have every chance to show what it could do Given that my most used lenses on my SLRs were the 50mm and 135mm, I had those in effect from the off in one lens. OK, they're not as quick as primes, but that isn't an issue for me. When I bought the X-T5 my intention was to buy a full set of primes over time, but I'm not feeling the need to at the moment. Am I missing something here? Genuine question. Don't be afraid to point fingers and laugh if I am missing something. I'm a big boy and I can take it! But, yes, that is my question and my quandary before I commit any further money in the Fujifil/Fujinon arena. 
    • Tomaz, do you see the flickering indoors with artificial lighting, or also outdoors in natural light ?  When I am at low f numbers e.g. 1.4, 1.8 with a shutter speed e.g. 1/125 and with a scene lit by a fluorescent lamp @50Hz (a simple lamp without an intelligent driver, for example Helvar, that operates at higher frequencies), I see this “flickering” in the EVF like you do. That is caused by the interaction between the frequency of the light source with the EVF refresh rate. You can use Flickerless Shutter Speed Setting to eliminate this effect. 
    • Good morning, people. I'm a recent convert to mirrorless and an even newer convert to Fuji, so please, if my questions appear foolish, make allowances, please!
×
×
  • Create New...