Jump to content
Sign in to follow this  
jedilost1

XT2 and XPRO2 Out of Stock

Recommended Posts

Advertisement (gone after registration)

Hello Everyone,

 

Long time Fuji shooter here.

 

I recently placed an order for an XPro2 (and possibly an XT2 as well) from a local retailer.

 

I was told they were out of stock in store and actually, Fuji film distribution has notified them that they are out of stock there as well.

 

I've also heard from others that this has been their experience as well

 

Has anyone heard something similar to this?

 

Has Fujifilm announced an ETA of when they will be instock at their locations and able to ship?

 

I'm guessing this won't occur until the holidays..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By lifewithlouis
      Love Child⁠⁠
      Toronto, Pride Parade 2019
       
    • By Bradley Stearn
      I've been trying to save 2 different colour presets onto my X100f. I've been inputting the presets for a HP5 acros look, and a kodachrome look based off classic chrome.
      I go into the Q menu, create the look on a custom setting, so for example the Hp5 look on C1. I then make the Kodachrome look on C2. The C1 Hp5 look is then deleted. What am I doing wrong? How do I save multiple colour profiles at the same time?
    • By FenFotos
      Spring 2020, in the heart of the pandemic. Walking the dog (or vice versa) along Riverside Park, masked and safely distanced. That's the George Washington Bridge in the background. Shot with Fujifilm X-T2 and Acros-R film emulation.
    • By ibraxwane
      Hi guys,
      Hope you're all well.
      My Fuji randomly stopped turning on a few weeks ago. The screen turns on but not completely (as seen on the attachments). Changing to the Viewfinder also doesn't work, shutter doesn't go off...nothing works. When I turn it off, the screen stays on; I have to remove the battery for my camera to shut down. I've interchanged between my 3 batteries multiple times, and the problem persists.
      I've looked for solutions on forums, but never found anything that fits. Tried updating the firmware through an SD card but the camera won't even turn on for the update to begin in the first place.
       
      Any tips? I'd love to hear from you guys!
      Cheers,
      Ibra

      Hello guest! Please register or sign in to view the hidden content.
      Hello guest! Please register or sign in to view the hidden content.
    • By Nicofit
      Good morning,
      I have a problem with my x-t30
      I'm not able to record any video because after a few second the video is automatically stopped and I can't understand why.
      I can't record more than 8/15 seconds.
      Does anyone know which is the problem?
      Many thanks
      have a nice day
      Nico 
  • Posts

×
×
  • Create New...