Jump to content

X-T30 Shutter button problem

Recommended Posts


I was taking photos and a friend asked to take a photo. Stupidly I didn't put the strap around their neck and they dropped my X-T30 camera with flash attached. The flashgun detached and thereafter I was unable to use the shutter button to take a photo. It will depress to autofocus is all and the green signal lights and sounds.

I can still take photos using the touch screen but I have never worked that way and its not something I want to embrace really.

I have tried the Reset to Factory and still no working shutter.

Is this in need of a visit to a service centre (I'm in the UK) or might it have set some weird button setting in action when it was dropped (4 ft onto carpet)?

Thoughts very welcomed

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...