Jump to content

fujifilm xt-30 ver2 firmware issues


Recommended Posts

i updated my fujifilm xt 30 two days ago and here is a few huge issues i encountered.

  • not charging when using a usb c pd charger, which worked until this update
  • not charging when using usb cable connected to computer
  • not able to connect to computer via usb, it's not detected in computer or camera after this update
  • battery life has basically halved after this update 

all these issues need to be fixed asap. and i updated this firmware using the phone app, so that's a difference this time. and if anyone else have any solution, please let me know so that i can try those too.. since right now camera is basically useless for me, until this is fixed.

Link to post
Share on other sites

also i noticed now that i am not the only fujfilm xt-30 user who's experiencing issues after version 2 firmware update. so anyone who have issues after this version 2 update please list your issues under this thread, so we can know all the issues found so far in a single thread and that will be helpful to fix the issues in the next update. or to share the fixes we find for each issues. thanks

Edited by YOUTA
Link to post
Share on other sites

update : the charging and file transfer issue is fixed.

i was searching for ways to downgrade the firmware after posting this, because i read some articles that it fixes etc.. but didn't found any ways to do that.. but i found that we can actually update the firmware again with the same version of the firmware file. so i downloaded the firmware again and this time i didn't use the fuji camera remote app, i used card as always and updated it again and the issues were fixed, i haven't tested the battery life, but i am hopeful that it's fixed too since other issues are fixed by doing this. so anyone who got issues after version 2 firmware update, please update again using card and see if that fix the issues. if not then add your issues under this thread. also never use fujifilm camera remote app to update firmware, it's the first time i used app to update and i got enough issues by doing it. have a great day everyone.

Link to post
Share on other sites

  • 2 months later...

I have tried to update the firmware version of my XT-30 from 1.51 to 2.0 without success. When I use Cam Remote, the App indicates that the camera already has the most recent software. If i use a memory card, the camera indicates that it is not possible to find the software in the card. What else should I do to update the firmware?


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

  • Posts

    • Hi all. After a long break from photography I've decided to get back into it and am about to purchase a Fuji X-E2 body (which I deem more than adequate for my needs at this point).    I had previously shot Canon but could never really afford decent glass for it. But I see times have changed and not only do Fuji seem to have some reasonably priced XF lenses, there are a number of recommended 3rd party manufacturers in the game.   I am still very much on a budget but don't need much for my particular interests. Thinking a 10-12mm, a 23-27mm and a 35mm should meet my needs (mainly street with some landscapes) and perhaps a 50mm or 60-100mm later. I'm only interested in prime lenses and reckon it comes down to a decision over whether I want AF or not.   Been looking at the Fujinon f1.4s which tick the boxes but will take me a long time to purchase given my financial situation. Happy to take it slow though if that's the general concensus (would be happier with one very good lens than three average).   The other option is the MF offerings from 7artisans, TTartisans and the like. I could pick up a few with very wide apertures (up to 0.95) very affordably. But I'm interested in the opinions of those who have used and compared them both (Fuji and non-Fuji). I don't have any natural objection to MF as I used it way back for film, but I haven't shot a mirrorless digital with a manual lens and never used zoom focusing, focus peaking etc. From what I've seen it's pretty quick and straightforward if slightly slower than AF. I must admit that the AF on my old canon DSLR used to annoy the hell out of me with the incessant hunting for focus and noise. But that was a long time ago and I'm guessing things have changed (these were also very much lower end Canon lenses).   I've had a search already, but if anyone would mind offering their opinions based on experience I'd be very grateful.   Many thanks...
    • I had this problem. I toggled between the two image disp options (full screen/small window) for OVF in the menu, and now it works again. 
    • Same here with a x h2s connected to a raveneye, losing the raveneye made my recording stop 😭
    • Welcome, dear visitor! As registered member you'd see an image here…

      Simply register for free here – We are always happy to welcome new members!

    • Hey All! I'm new here and desperate! I just upgraded from my XT3 to an XT5 and need tethering advice. A huge part of what I do is tethered shoots and I've been successfully tethering my XT3 with Fuji Tether Pro Plugin to Lightroom for years. It is essential that the software can fully control the camera. First of all it was very difficult to update the existing plugin. You have to remove it and reinstall it,  which doesn't work properly.  In the end,  I had to manually unzip the downloaded update file and enter in the code myself. More importantly.  The update does allow you to focus and take photos but the settings control doesn't work. That's means you can not adjust ISO,  Shutter speed or f-stop with the software. These buttons simply don't work when you click them. Has anybody else experienced this?  Is there perhaps a previous version of the update does work? Has anybody managed to tether with Capture one?  I read there are also bugs. I'm willing to switch systems if it fully works. If I can't fix it I'm stuck with an Xt5 that I paid a lot of money for that I can not use for its intended purposes. 
  • Create New...