Jump to content

Fuji 100s & the new xApp


Recommended Posts

Hello everyone,

I was wondering if Fuji finally fixed the new xApp as they promised on May 31st.  Also, has anyone started using it?  I'm also hoping Fuji ports this over so we can use it with the 50r and the XH1.  

I've had no issues with he old app and will still use it with my other cameras, but I was considering switching my 100s over to the new one.  Any assistance is greatly appreciated.

Link to post
Share on other sites



It works on my X-T30, so far. It has one feature to be careful regarding using it. GPS support is an “always on” requirement to be able to use the app. Additionally, the GPS will need “use precise location” turned on, this is no biggy, it means the GPS is using the phone’s GPS location rather than the older less precise method of using wifi location.

But, having the GPS always on is more troubling, because while you can turn that on and off in the phone’s main setting menu, you have to have it on just to use the app for any of the other remote’s features. So it is running in the background using your batteries (camera and phone) even if you do not want location info embedded in the image files. Remember to turn this (use location setting) back off in the phone’s main settings menu after you are finished using the app or you could potentially drain the batteries while it is running in the background.

Link to post
Share on other sites

After lengthy discussion on a different forum it seems there may be issues if you want to geocode images and you use an Apple device.

Whichever phone you have its necessary to first connect phone and camera via bluetooth (and turn on the geocoding and location sync settings in the camera).

Apple devices will continue to send updated locations to the camera while the phone app is in the foreground OR the camera remains active. When the app goes into the background and the camera sleeps or is turned off and on it won't reconnect.

Android devices will reconnect phone and camera even if the app is in the background.

Only an issue if you are interested in using the app for geocoding.

(The requirement for "always on" even if you are not geocoding seems like lazy programming but I doubt it has a really serious affect on the battery.)

Link to post
Share on other sites

THANKS Jerry and Greybeard.  This is very helpful!  I do use geotracking.  I'll have to test that.  I was actually surprised this app still ran on my iPhone 7s which is six years and six months old!  I'm keeping the old app just in case I didn't have too many issues with it and was reasonably happy.  I'm actually looking forward to the new app primarily for the Activity feature.  I wonder if it captures the total of shutter actuations on the camera?

Thanks again guys!


Link to post
Share on other sites

12 hours ago, jlmphotos said:

 I wonder if it captures the total of shutter actuations on the camera?

Thats an interesting question - there appear to be two different remote access interfaces to the camera : Bluetooth/Wi-Fi and USB - the USB interface does have a way of accessing a shutter count - I haven't seen any report that its available via Bluetooth/WiFi.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

  • Posts

    • It is/was not what I was used to (5D3, R6) in terms of color and WB. Using Kelvin manually is just like another top dial. Something to do to get it right in camera. 
    • I don't think there are Fuji "FX" lenses or mounts, it's "XF". If I had your camera I would buy any XF or XC lens and expect it to work. I do have an X-T30 ii, pretty similar. I have lots of XF lenses. XC lenses are made by Fuji and are cheaper, if it's cheap you want.  I wanted a lens with very few elements or element groups, and bought a Pergear lens for about $59 new. It only has 4 elements in 3 groups, IIRC. I also plan to use it if I ever think I might ruin the lens, like shooting something dangerous.
    • Buonasera a tutti, qualcuno usa Saal Photo Portal per vendere le proprie foto? Funziona? Grazie,
    • Please help me before I send it back. Do I have a bad copy of Fujinon 33mm f1.4? I find it really soft off center (not even corner). See print screens. I focused on the same spot, just moved focus point. I get same result over and over again. (EDIT: After more testing I find that I can get sharper results off center but it's very inconsistent and not at all reliable. Focusing issues? It's not the camera, Ive have tried it on 3 different cameras)

      Welcome, dear visitor! As registered member you'd see an image here…

      Simply register for free here – We are always happy to welcome new members!

    • Hi everyone. I'm new here. I recently bought an X-S20. It's really a decent camera but i encounteted something odd. I linked my X-S20 with my phone via wifi using XApp. I enabled Auto Image Transfer Order so that images in X-S20 will be sent automatically to my phone whenever Xapp is activated. When the camera is switched off while there are images queuing to be sent, the indicator lamp on the camera blinks green and orange. I know it is normal since it is only completely turned off until all images are sent to the phone. But sometimes the image transfer is discontinued due to connection problem or else. The problem is, after being disconnected, the camera seems not to identify the disconnection and keeps on blinking green and orange. If i switch the camera power button to ON, the camera will not show any response (but continues blinking). The only way to fix this problem is to take the battery out and put it bavk again. Did anyone also encounter this problem? I would like to know how to fix it.  
  • Create New...