Jump to content

can not open RAF files via Mac OS Preview or Pixelmator Pro

Recommended Posts

Hi, I have new X-T30 II with latest firmware and I can not open RAF files on my Macbook Pro 16 M2 Max. My Mac OS is in the latest version and I also use Pixelmator Pro latest version.

I try to change settings on X-T30 II to uncompressed RAF file, also to lossless compressed and compressed, but the same problem. With older body X-T4 I have not this problem, only with this new X-T30 mark II.

Have you any advice?

Edited by Stepan Razin
Link to post
Share on other sites

Apart from wait none I am afraid to say. I had the same with the GFX 50 files to begin with. However, 'DxO Photolab 6' handles them perfectly. Also when you upload a file taken with a lens not yet in its database it will auto suggest you download the corresponding file. I have two Fuji cameras and 5 lenses all of them now recognised by this software which I am very happy with.

Link to post
Share on other sites

42 minutes ago, Greybeard said:

Frustrating - Apple does now support uncompressed raw from the X-T5 and X-H2 which were released a long time after your camera. (Compressed raw isn't supported from any FujiFilm camera)

Yes I know, that I must use uncompressed RAW format only to open or edit, but now, nothing works. Only JPEG 😕

Link to post
Share on other sites

According to this:


Apple does not yet support the X-T30 II. There are some options you can try.


Use this (it is free) to convert the raw files to TIFF, which you can then edit in your current editor.


Use an EXIF editor to change the camera name in the raf’s exif tags to X-T30 — version one — and then the Apple support should be there. I do not recommend this other than as a last choice option.

Edited by jerryy
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...