Jump to content

fuji xt10 display photos button problem


areekw
 Share

Recommended Posts

  • 2 months later...

I am having the same issue and had the camera sent to the repair service under guanrantee. They pretend now that I did cause the damage. During my holiday, I just put some scotch to keep the button horizontal and working no other way to still use the camera. Seeing some tiny trace of adhesive the repair service said I have to pay for this repair (no guarantee): 130€ What can I do to get this properly handeld under the guarantee as this seems to be a well known defect of this model?

Link to post
Share on other sites

This is such a pity.... I have handled the camera to the local fujifilm service and I'm waiting for their call. They told me it would take 2-3 weeks for the parts to arrive. If I have the same problem I would contact Fujifilm directly via email, then print their answer (if they approve the guarantee for this defect as someone in another forum said) and bring it to the repair center.

Link to post
Share on other sites

  • 3 months later...

Advertisement (gone after registration)

I found a way to fix the issue: rotate the button back into position (turn it clockwise) using an X-acto knife. Then place a small square of duct tape over the button to hold it in place. The square must be large enough to stick to the button and some of the metal around it. You can still use the button through the tape, and the tape prevents it rotating back into the bad position.

 

My X-T10 is out of warranty, and the thumb rest has fallen off, along with the rubber grip material on half of the camera, and this button failure. I haven't abused this camera - they are simply not built to a very high standard, I'm afraid. It still takes wonderful pictures, but I can't say I would recommend anyone buy one of these.

Edited by davidmold
Link to post
Share on other sites

The point, self evidently, that I was making was not to take away your problem, it's an issue for you, but to suggest they will be lots more good batches than bad. If it were more prevalent I would hope a recall, as with other manufacturers, would be carried out.

Edited by MirrorMirror
Link to post
Share on other sites

  • 2 years later...
On 12/14/2016 at 4:10 PM, davidmold said:

I found a way to fix the issue: rotate the button back into position (turn it clockwise) using an X-acto knife. Then place a small square of duct tape over the button to hold it in place. 

2019, and thankful to have found this easy solution, thank you.I thought it was pressed inside or so.

Link to post
Share on other sites

  • 1 year later...

Hi all. I own a Fujifilm XT-10 and the playback button rotated and no longer works. The rubber on the thumb rest also fell off. I’ve been in situations the last while where I really needed/wanted to use the camera so I haven’t had a chance to get it repaired. I’m now a few hours away from a Jasper and Banff National Park trip with no playback button. So yeah. Kinda blows. I tried switching another button to playback function but that’s not an option. Should be for emergency situations. My camera is not under warranty anymore. But reading this forum makes me realize I’m not the only one with the thumb rest rubber issue as well as the bigger issue with the playback button. If this is truly a defect issue, Fujifilm should repair with or without warranty. Otherwise still loving my little beast. 

36CB9825-24D7-4308-BB10-0DE360FB71DC.jpeg

F5805A21-1B97-43A1-80E7-0058E66150F2.jpeg

Link to post
Share on other sites

  • 3 weeks later...
On 5/27/2016 at 5:08 AM, areekw said:

Yesterday I saw that this button has rotated and then i couldn't use it. Now when I'm rotating it back its working but it is annoying.
Has anyone had a similar problem? Any solution without sending it to a service? 
 

post-13841-0-96081400-1464347288_thumb.jpg

Same just happened to me after having this camera for over 3 years, what you guy recommend to fix this problem?
Thank you!

Link to post
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...