Jump to content

Fuji X-E3 Loss of Settings with a change of battery!


Recommended Posts

Found an old topic with exact same problem on an other camera model. After some googling and watching some teardown videos on YouTube, I have not found out, what kind of battery is inside the X-E3. If someone knows it or had already a replacement, I would appreciate a comment.

After some investigation and testing, I am quiet sure, that the internal battery gets only charged from USB. If the main battery voltage is high enough, the voltage is superseding the internal CMOS battery and prevent discharging. Just to put a full battery in the device seems not to help at all for CMOS battery charging. > Put a battery in and connect to USB from time to time to preserve the CMOS settings!

My problem was, that I had sometimes used the Fujifilm DC Adapter, which is basically a fake battery with a DC cable attached to it. I only used the adapter for a month, but it was enough to kill the internal CMOS battery!

Temporary workaround: If I connect an USB power bank during battery swap, it seems to prevent the lose of settings, time and pairing.

Very annoying that that they implemented such a faulty design across so many models! - Modern Real-Time-Clocks consume almost 0 uA and flash storage for the settings should also be around for free. No need to use SDRAM. A supercapacitor should power such an RTC for over a half a year easily and also would recharge at any point in time not like a lithium battery which will go bad for sure.

 

Link to post
Share on other sites

That sounds very strange. I have three X series cameras,  but admittedly not an X-T20.  On mine the internal battery is maintained perfectly by the replaceable battery. I don't see why it should be different for the X-T20. I think you have a faulty camera. Contact your nearest Fuji repair centre and ask them about it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

  • Posts

    • Hi Jerry, thanks so much; I already downloaded Rawtherapee v5.8. But as I am using Mac OS 12.6, probably there is some issue. There is an instruction in their website  '  Drag sh into the “Full Disk Access” pane under the “Privacy” tab in the “Security & Privacy” control panel in “Apple menu” > “System Preferences”. I tried to do but couldn't do it. So I didnt have the access to the photo folder. I already had other raw converter. Are all the data in TIFF kept as same as RAF? then I can edit it in darktable or Lightroom ( I have older version in my different laptop). 
    • My Fujifilm x100v resets the date to january 8 2000  it happens about twice a year. my personal settings rest unaffected.  I use firmware 2.13 is there a solution to this very annoying problem(bug)?    
    • Hey Guys, I am stumped. I am trying to use the Movie setting on my X-T200. I push the camera through an Elgato Cam Link so that my PC can use it. I am currently running into a problem that I turn off the Face/Eye Detection however it will still show the green box and white eye box. I still wish to use the auto focus but I do not need the Boxes present. Does anyone know a fix? Or is there a better setting I can use to allow auto-focus but remove said boxes. I am still new to cameras and do not want to go out and buy a brand new one.   Thanks.
    • Okay a quick follow up to my own post; I tried re installing the firmware on my camera, and the issue seems to have gone away (I had the latest on the camera already, but I re downloaded it and re installed it overwriting the old installation via the instructions on Fujis website). My guess is that maybe the firmware got corrupted during or sometime after my previous install. I will keep tabs on it if it starts doing it again.
    • You might give RawTherapee a try: https://rawtherapee.com Or, if you are using macOS or Windows, Fujifilm has a raw converter based on SilkyPix: https://fujifilm-x.com/en-us/products/software/raw-file-converter-ex-powered-by-silkypix/ It give you some options for basic editing and touch-up for your images that you can then export as a tiff and finish in GIMP or your favorite image editor, or as jpg if that is enough.
×
×
  • Create New...