Jump to content

Any news about a FW 4.0 update on the E2?


Recommended Posts

Advertisement (gone after registration)

Well, they are also steaming on with the X-E2-S ( not 3 apparently, at least according to the rumors of this forum, however reliable they might be).

 

The fact that this update is this late it shows, to me, that they had to reconsider their marketing strategy and engage very late into providing an update that they might not have programmed at all at first but them, when Fuji saw the level of hostility that that cause, were forced to reconsider.

 

I too am waiting to see what the future would bring. Very likely I will buy a X-E2 if price drops. If they keep on pricing it the same price of the X-T10 I am afraid that it will lead me to different choices.

Link to post
Share on other sites

Things like camera model designations, which were decided at the time of the introduction of each of the past models, could have been changed by the successes or failures of past models.

 

So, the X-E1 was at first followed by the more powerful and sophisticated X-E2 which would let us to suppose that past the X-E2 there will be a necessary progression into X-E3 , yet, rumors have it that they would chose for X-2S... we will know why that is when the time comes.

 

The fact is that the X-E2 has been surpassed by the X-T10 ( which is less expensive and sophisticated than the X-T1  which makes impossible to progress, for that top model, past series 9...  ) largely by way of software.

 

We were told ages ago that “ soon” the X-E2 would have got some firmware upgrade but then rumors died down and sales too.

 

Now, after months of that stalemate ( camera on the market at the same price of the newer and better X-T10 ) they have finally started to discount it ( at least where I am ) and now they are selling it at less than the X-T10.

 

Yesterday I went to my favorite shop and asked if that had had any impact on sales and they said that nobody had noticed that yet.

 

But my guess is that potential buyers (such as myself) are still holding on to their savings and waiting for any software update.

 

Should this come and be unsatisfactory containing too little innovation, I will have to think long and hard whether I want a camera with reduced capabilities compared to a X-T10.

Link to post
Share on other sites

  • 3 weeks later...

Once the release of FW 4 and the announcement of a new model -XE2s- is now confirmed, my guess is that despite sharing of sensor, processor and EVF panel with their siblings, the XE2 ad hoc circuitry which served to this devices is at the top of its capabilities (same happen to the XP1).

 

Thus, the new FW 4 would bring only some features currently present on XT models (such as AF, GUI and button-functioning but e-shutter). 

 

I guess the XE2s is an update of XE line for two reasons: keep the hype on this line of cameras up to release the XE3 [which should be and XP2 with EVF only and not weather sealed] and maybe Fuji is trying out new hardware tech inside ;)  to be used in future models.

 

Let's wait and see...

Link to post
Share on other sites

Advertisement (gone after registration)

Well I just about wet myself when I read the details of the 4.0 update. There is SO MUCH in it, for an oldish camera, delicious!

 

I can only imagine that owners of other camera brands will be looking on enviously at how well Fuji looks after their customers, yet another factor to persuade them to jump ship and come to Fuji. :P

 

27 improvements and enhancements, phew! Talk about getting a new camera, this is so exciting, how can you not love them for it.

Link to post
Share on other sites

  • 2 weeks later...

Pretty thrilled with this update. Process went smoothly and - I used to scoff at this - it IS like getting a new camera. In a good way. But on the other hand it also means that some time will be needed to absorb the new features and changes. Be patient and take the time. I wouldn't update 10 minutes before a paid gig or once-in-a-lifetime event. I'm really digging my X-T10 in an RF-style body.

Link to post
Share on other sites

Pretty thrilled with this update. Process went smoothly and - I used to scoff at this - it IS like getting a new camera. In a good way. But on the other hand it also means that some time will be needed to absorb the new features and changes. Be patient and take the time. I wouldn't update 10 minutes before a paid gig or once-in-a-lifetime event. I'm really digging my X-T10 in an RF-style body.

 

I think it's pretty straightforward and self-explanatory WHAT the new functions are doing. As for HOW to use them best, there's already my X-T10 (e)book. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share


  • Posts

    • Thank you for checking, I have just observed the same behavior with the 35mm f/2 - X-S10 with v2.10 chooses 1/100s. I guess I will use the specific minimum shutter speed or simply force myself to use the M mode more. 
    • Can I ask, what type of audio are you looking to capture?
    • Hi All, This is my first post. Hope this hasn't been covered before. I have something I'm trying to figure out on my x100v. I typically have my camera in natural live view with "Preview Exposure" off because I don't like seeing my exposure settings reflected in the image in the EVF. However, it seems that, in this setup, the live histogram no longer adjusts based on my exposure settings... Is there any way to get the histogram to show results based on what the resulting image will be without having the EVF brighten/darken based on exposure settings? With "preview exposure" on, I find it hard to compose-- especially in certain situations when trying to protect the HL's. Thanks very much! Collin
    • Hi all,Second post here would appreciate the input. I just purchased an X-T3 and X-H1.The EVFs on paper are meant to be the same with same refresh rates when in boost mode.The sizes are also meant to be almost exactly the same at 0.50 inches X-T3 and 0.48 inches X-H1 with the same resolution.However the X-H1 EVF feels smaller (bigger black border around the edges) and not as clear. It also gives me eye strain after just a few minutes. (I have adjusted diopter). It feels like its further away if that makes sense?Has anyone else noticed a difference between the EVFs when using them side by side because on paper they are meant to be the same. Perhaps its just this particular X-H1.Thanks,
    • I must have activated the wrong setting because now when I switch to the OVF the white windows stays for a second and then completely disappears. Any idea how to get it back? Thank you all so much. 🙂
×
×
  • Create New...