Jump to content

xt4 microphone jack broke


jross16
 Share

Recommended Posts

hello everyone. having a bit of trouble. my rode video mic pro picked up on my sigma 18-35 mm lense autofocus noise during shooting, so i attempted to remove it from the hot shoe and have the mic attached to my tripod. it fell from my (not very well secured) position on the tripod, and not my port is not working unless i press the jack into the port with a bit of force. is there anything i can do to fix this myself? thanks. 

Link to post
Share on other sites

Usually all the ports (mic, headphone, usb, hdmi etc, ) are soldered on the mother board, technicians at the authorized repair facility will not bother to resold the damaged part, but simply will replace the main board.  Translared it means 500€ or so.

This is a typical modern approach followed practically by all manufacturers. Simplier for them, dearer for us.

Fuji is not an exception as they are used to replace all the top assembly of a camera. (including the evf) even if just one dial is malfunctioning, and this mean 300€...

 

Gaetano

 

Link to post
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...