Jump to content

Viltrox 85 mm II for Fujifilm x

Recommended Posts

Hi, Help please anyone;

Bought a new Viltrox 85mm for Fuji and it worked perfectly for a few weeks on my X-H1.

Suddenly I press the shutter button to take a shot and it starts clicking away endlessly.

Shut the camera off an it still continued for a few seconds before shutting down. Tried all the usual, turn on and off.

battery out and back in. Tried the lens with 3 different Fujifilm cameras XT-100, XT-200, and The XH'1

Exact same problem with each and replaced Viltrox with Fujifilm X lenses after trying Viltrox 85 and no problem with Fuji Lenses attached.

Any help from members would be greatly appreciated, heartbroken to say the least and the Viltrox images were stunning and beautiful before this happened.

Talking about maybe 200 images before the endless clicking shutter or whatever sound took over.   Thanks   GO







Link to post
Share on other sites

No I haven't done any of those things because, as stated, the lens worked perfectly until the problem arose.

I reset the cameras to default and the problem persisted. Must be something in settings is what I thought or the lens is defective but how does it change so dramatically after working perfectly and taking a perfect picture the shot before the problem arose???   Thanks for your interest and reply  

Link to post
Share on other sites

if you bought the lens new and you can still return it or send it to warranty just do that...don't wait for some miracle

if not then update one of your cameras (i'd say the newest one) to the latest firmware and then the lens and see if that works, if that still doesn't solve your problem contact viltrox as they're quite helpful from what i've read online. 

but the main idea is to have both the camera AND the lens at their latest firmwares. it happened with my viltrox 56 that it wouldn't work anymore after i updated just the camera, then after updating the lens it wouldn't work with another camera with older firmware, then finally after updating all my cameras to the latest version it works fine.

oh, and for some reason, don't just download the latest firmware for the lens, but also all the versions in between the latest and the one you have installed and update in order...just how viltrox works i guess...

Link to post
Share on other sites

  • 1 month later...

Must be the firmware. I have this lens and the 33, which are great btw, and had a problem with the latter.
I tried to update to the latest version, the problem is there are two, a white silk screen and a golden something.
Once the updated was done, the lens started to focus continously.
I deleted all the updates and installed one of the two, I don't remember which one.
Then the lens worked perfectly.
The problem is the Viltrox customer care doesn't exist. I tried to contact them to know the difference between the two updates, but nobody ever replied.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...