Jump to content

18-55 will not lock to XT-20


airbusky
 Share

Recommended Posts

Advertisement (gone after registration)

Was just shooting this morning with my 18-55 and XT-20 and all was well. Picked it up this afternoon and screen was grayed out and showing f 0. Checked the lens and it is not locked to the body. Tried another lens (23 F2 WR) and everything works fine. 18-55 still will not lock to the camera and is not functioning.

Any ideas? Thanks

Link to post
Share on other sites

Check the mounting plate on the rear of the 18-55.  Make sure the screws are tight. Sometimes they come loose, and will interfere with mounting.  I have two copies of the 18-55 and my one copy has had that happen due to constant use. I would also clean the contact points on the lens just for sh*ts and giggles.

Doesn't sound like it's the camera body itself if other lenses work.

Let us know how you make out.

Link to post
Share on other sites

Thanks Jorge,

I checked all of the screws and they are tight. I have now discovered that the lens is looseing contact with points if rotated all the way onto the camera. Rotating it back just a bit will put the lens back into operation. The lens is still not locking onto the body. I have had this lens for years with moderate and careful use. Disappointing. My other prime lens works fine on the body so I agree that it is the lens. Any repair shop recommendations? I'm on the west coast.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...