Jump to content

X-E3 r-dial broken (again...)


Recommended Posts

Advertisement (gone after registration)

Hi all guys, a few months ago I sent this camera for repair because the r-dial command was broken (purchased in March and used 3 times), the assistance service took about 1 month and a half to repair. Yesterday after some time I used this camera again and ... same problem the command broke again 😭. Now I think I will no longer send her for assistance, I ask if anyone had the same problem as me and how they solved it or if they found a way to configure shutter speeds.

IMG_20211128_190016.jpg

Link to post
Share on other sites

  • 2 weeks later...

The push function on the rear-dials of the 'earlier' X cameras is quite prone to defects. I believe it was solved in the X-H1 and the X-T3 thereafter, but X-E3's have the earlier internal design. The push function could 'stick' in one function or between functions causing the rotate function not to work properly. If that happens, internal cleaning or replacing is the only option. Something that (most of) you can't do yourself.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...