Jump to content

T2 refusing to turn on


Recommended Posts

Advertisement (gone after registration)

Ok, so I bought a camera (Fuji xt-2 with 18-55mm) off of my good friend back in June of this year, and I had used it a fair number of times no problem, taking photos while on holiday and around London to do some street photography. I was in London just yestaday and I went to take a picture and as I was about to take it the screen froze. I didn't quite know what to do so I left it a little bit thinking it might come back but it didn't, and even when I turned it off with the switch the frozen screen was still there, so I took the battery out and turned it on again and it wouldn't turn on full stop. So when I got home I charged my official fuji battery thinking it might be the batteries fault, but I put it in the camera and turned it on. Fully charged overnight, it worked for about 5 seconds, told me I had no memory card because I took it out and then showed the no battery sign and turned off. I turned it off and on again and held on the viewmode button and display button, and it brought me to the language screen so I am assuming it factory reset it, again it said no battery and shut off, I did the same again and this time the screen turned a light green sort of colour (I am colour blind) with white streaks going through it, once again switching it off did nothing and once taking out the battery it went away, and now it won't turn on again. However, I will say that something does happen when you turn it on, as I can hear a sound, I don't really know what it is as I am fairly new to photography and cameras, but it sounded like the shutter moving or something similar. Anyway, any help would be greatly appreciated as I spent a lot of money for my first camera.

Edited by brynnyaboi
Link to post
Share on other sites

  • brynnyaboi changed the title to T2 refusing to turn on

Update: Okay, so I have 3 batteries. The fujifilm and one of the off brand batteries seems to not work at all, causing the camera to not turn on or glitch out. But I tried one of the other off brand batteries and it worked, turned on as normal, I was able to take photos and I put the memory card back in and all of my photos were still there, so it seems that the Fuji official and one of the off brand batteries are kaput? I don't really know I was able to turn the camera on and off consistently with the one that worked. Maybe its just a big conicidence that both of those batteries died at similar times? Or is there something else?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...