Jump to content

7Artisans 50mm f/0.95 large aperture portrait lens launched


Klaus Armitter

Recommended Posts

I have the 35mm f/0.95 and loved it a lot. It performed well on my X-T30. And now the 50mm has been launched, looks great, maybe I will buy the 50mm one if it can be cheaper.


SPECS:

7 elements in 5 groups
13-blade diaphragm
de-clicked aperture (I do not enjoy with the de-clicked aperture, but thinking it will be better for vedio shooting)
Price: $200↑ (I’m waiting for the price drop, hope it will drop soon)
 

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

Link to post
Share on other sites

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

  • Posts

    • Thanks. I initialized the camera and went ahead and entered all my settings again. Things seems to be working ok, now.
    • Do you have a Custom Setting Selected? https://fujifilm-dsc.com/en/manual/x-t5/menu_shooting/image_quality_setting/#select_custom_setting If so then you need to edit that custom setting to remove the functions you don't want https://fujifilm-dsc.com/en/manual/x-t5/menu_shooting/image_quality_setting/#edit-save_custom_setting As an alternative you can enable Auto Update Custom Setting and then any changes you make will be remembered when the camera is turned off https://fujifilm-dsc.com/en/manual/x-t5/menu_shooting/image_quality_setting/#auto_update_custom_setting
    • Just got a new XT-5 which I upgraded to from the x100v. Have also used XT-3 and xPro-3, so am fairly familiar with the X series. The XT-5 is very nice… and a little perplexing. I turn off the face detection setting as well as interlock spot AE & focusing area because I don’t want to use those features. I turn the camera off, turn it back on, and, lo and behold, both those features are back on. Gremlins? Latest firmware up grade? I am at a loss. My BW film recipe has the two features turned off when I scroll through them on my Q saved menu items.  Any insight is appreciated and thanks.
    • I believe the only way to do this with the X100S is to switch the autofocus button to MF and use the AFL/AEL button. The X100S doesn't have the option for back button focus in AF mode like more recent X series camera models.
    • I don't think its possible - you could do the opposite (keep it on) with some tape - but not sure there is a way to keep it off (although like Jerryy says - it would certainly chew through the battery even if you could)
×
×
  • Create New...