Jump to content

Recommended Posts

Yesterday, for the first time, I took my X100V with me on a hike without its camera bag. I noticed that opening this bag creates a barrier when taking photographs so I wanted to try without. When I wanted to put the strap on properly, my camera flew through the air on the hard stone street. The result was a clear damage to the black metal (top and button). Later it turned out that also the battery seal did not work anymore.  The camera seems to work fine (?) for the rest. The fans among you will understand that I was very upset. The camera is less than a year old and I am very careful with it. What can I do? Have it repaired (can you remove these damages?), have the camera checked completely? A new battery cover? Sometimes I think: exchange it and pay a bit of extra, because as a nature photographer I want a 100% reliable camera. I have never experienced this before: what is your advice? Many thanks!

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

  • Posts

    • Hi All My XT5 tells me that my newly formatted 64gb card has a capacity of 183 photos, which is much less than it had previously.  It also tells me that by 32gb card has the same capacity which sounds about right.  When I put the cards in my XT20 however the capacity of the 64 gb card is double that of the smaller one which is what I'd expect.   Daft laddie question - why?  Is it me? Thanks Ian 
    • Congratulations on your new camera ! I wish you that you may enjoy it for a long time. 
    • It sounds ilke you have the drive dial set to Multiple Exposures, the one next to Adv2. Turn the dial back to S or CL or CH and the camera should go back to the way you are used to it behaving. p.s. Welcome to the forum.
    • My Charcoal X-T50 arrived today and here are my first impressions:  It's small. If you take away the flash dome it's the same size as my Leica D-Lux7. Its small size requires me to learn to grip it differently than my other Fujis especially my X-H2s. It's heavier than I thought it would be and feels heavier than my X-T1. I love, love, love the film sim dial and have programmed the C-1-3 with other Fuji sims that aren't designated on the dial. IMHO it's a beautiful camera that is laid out similarly to my other Fujis although the tiny joy stick will take some getting used to. I also love, love, love the digital 1.4 and 2 TC and have programed the back dial to initiate them. On one side of the viewfinder is the diopter control and on the other side is a programmable button that I didn't notice until programming the buttons showed it but it is a cool feature although difficult to get to if you are holding the camera to your eye. Things I don't like: It came with an uncharged battery. I've never gotten a new Fuji with a dead battery until this one. Fortunately I've got several of the 126s batteries that are charged. No hot shoe cover. I know this is supposed to be a budget X-T5 but come on Fuji a matching hot shoe cover doesn't cost that much. No manual. I know manuals are a cost cutback for camera companies and I've downloaded one from the Fuji site but for $1399 it should be included. These are first out of the box impressions and I have not shot with it yet or processed any images and will post some when I do.   
    • Well I just got back from a trip to drumheller and noticed that the lens seems to vignette quite severely. Is this normal for the lens, or is it an issue? I can correct it manually in capture one but I'd rather not have to for every photo
×
×
  • Create New...