Jump to content

x100s not working, can't shut down without removing battery

Recommended Posts

Hello everybody, 

finally got myself an x100 series camera again, unfortunately it seems to have stopped working. 

When I turn on the camera, the lens makes some noises but it never boots up fully. I can't press any button and it doesn't show anything on the screen(it's on, as it's a bit brighter than when turned off) . When I turn the camera off it makes a small beep (like when you select something in the menu) but the screen stays on.


The weird part is that when I tried to install new firmware it worked perfectly, screen is like normal. 


Any ideas or pointers?

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

Link to post
Share on other sites

  • 1 year later...

I might have found the solution, Ive been trying to fix my x100s on multiple solutions.
change settings

It looks like its a faulty ON/OFF switcher. 
What I did is: switch the switcher many times (really many times, 20 or more very fast)
it is working for me.

Link to post
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...