Jump to content

prime lens focus issues


Recommended Posts

Advertisement (gone after registration)

Hello all, my apologies if this topic has been asked before. I have the X-E2s model and normally use my 18-55 zoom lens. I also have the 18 f/2 and 35 f/1.4 prime lenses. Whenever I use these lenses it seems that the auto focus goes haywire. The lens is constantly chattering back and forth as if it is trying to focus. It does not matter if the camera is in the "auto" mode or manual. Or if the focus setting is single or continuous. The only time it stops doing this is when I switch the camera to the manual focus mode. The camera operates normally with the zoom lens but this drives me crazy when trying to use the prime lenses! I have checked the firmware on the camera and lenses and everything is using the most current version. Any help would be appreciated. I rarely use either of the lenses now because of this problem. Thanks, Jim White

Link to post
Share on other sites

Thank you, thank you, thank you!! That was it! I had it set to ON, now things seem to be operating normally. It does still act that way if I have the camera in the SR auto mode (I know I'm not supposed to use that!) Maybe I'll finish reading my owners manual someday...Thank you again, now I may start using these lenses some more, though I am fond of the 18-55. Thank you again, Jim White. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...