Jump to content

New X-S10 feels loose inside??


Aimee Lee
 Share

Recommended Posts

Advertisement (gone after registration)

Hello,

After falling in love with my X100F and out of love with my Canon R, I’m diving more into Fuji (eyes on Medium format next!). I received my X-S10 the other day and have only had time to shoot around the house, but I am so excited already, just with the 18-55 kit lens! 

My question is-has anyone else felt like the entire inside compartment of the camera is loose? When I excitedly unboxed the body, I turned itover and around to admire it, and immediately felt this gentle “clunk” of the insides shifting, However, when I turned the camera on, something engaged and must have tightened, because the looseness disappeared and it felt solid as a rock when turning it over.  Then, when I turned it off, the gentle clunk was felt again when turning or rotating the body.  So the problem is this internal “clunking” when off, but no internal clunking when on....

Do I have a faulty camera body? Or is that something to do with the design/mechanisms? The indoor pics I took look beautiful so no issues there....

I have a busy hospital job so thought I’d reach out here first due to my  limited down time these days.  I could also give Fuji a call when I have a day at home....thanks for any input! 

Link to post
Share on other sites

Much respect to you Aimee. Please be safe and thank you for what you do.

As for the "clunking" - does the same thing happen when its just the camera body? Or does it only happen when there's a lens attached to it?

With my X-S10, there is no clunking noise whether its body only, nor with either my XC15-45 or XF18-55 f2.8-4 lens attached.

The closest thing I've experienced with any clunking of sorts is with Sigma lenses. The lens would appear to have something moving internally (as if something's loose) but it goes away as soon as the camera is turned on.

Another possibility - the IBIS module. Ideally, there should be no loose components inside regardless of when the camera is on or off.

Edited by Joe Roxx
Link to post
Share on other sites

  • 2 weeks later...

Saw a similar issue in the X-T4 thread.

Since the X-S10's smaller IBIS module is based on the X-T4, perhaps this "feature" was carried over.

I'm glad my X-S10 does not behave this way. Though not a defect, personally speaking, it would be somewhat unnerving to have this occur. To this day, I find it mildly annoying that my Sigma 30mm lens does something similar.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Similar Content

  • Posts

    • Nope, still not fixed, do you have multiple autofocus lenses for it? If you do does it do the same thing for all the lenses or just one? Cause the camera throws out a lens error (the blinking red led light) but I can only try with one lens, so can't really troubleshoot more then in the video
    • Just adding for some more clarification... If, for instance, I choose a menu like the "Drive" and I choose "Continuous" and am presented with the horizontal list of values: 11, 8.0, 5.7, 5.0, 4.0, 3.0. If I use the Rear Command dial to scroll through them and say that my selection was on "11", then continuously turning the wheel to the right will just select 11, 8.0, 11, 8.0, 11, 8.0,... Also noticing that it will skip a click before it cycles back to the first value. Not that that's helpful in diagnosing anything.
    • Try a Fujifilm-recommended memory card: https://fujifilm-x.com/de-de/support/compatibility/cameras/x-t4/ If that doesn't help: go to the dealer and get the money back or buy another more reliable digital camera.
    • Hello everyone, Unfortunately this is my first post as a second day X-Pro3 user. I got it brand new yesterday. I'm using a manual M mount lens with a 3rd party mechanical-only adaptor, if that's relevant. I don't have any native X lenses. The issue I'm having is that the rear command dial will only change back and forth between 2 values and nothing else, regardless of context. This happens anywhere and any time the rear command dial functions. i.e. if it's set to shutter speed, it will only change between two values, for instance 80 and 100, regardless of whether the Shutter dial is set to a number or to "T". If set to ISO, it will only navigate between two values, for instance, 800 and 640, regardless of whether ISO is set to a number, A, or C. Etc for anything it is assigned to. If you press the wheel button in the EVF and get the focus magnifier aid to pop up, it will only scroll between 2 magnification values (are there only 2?). If you use it during playback it will also only switch between the "normal" image and the first notch of magnification: you can see a little "screen" graphic with a scroll bar appear above that and it will only scroll between the original image and the first value of the scroll bar. If I assign the front command dial to any of the assignable values: SS, ISO, etc it works fine. So this is not user error in these cases. I've  looked at every page/post on the internet that I could find that remotely resembles this issue and none are the same as what I'm seeing. I've reset the camera multiple times and updated to the latest firmware (from 1.23 to 1.31). Nothing has worked. I'm guessing it's broken unless this is something really simple I'm over looking. I'll be calling the shop tomorrow but  this was their last one and these are now impossible to get in NZ. So it's not looking good if this has to (ridiculously) go through a warrantly repair. Any help would be greatly appreciated. I hope this turns out to be nothing! Thanks.
    • Hello, I have the XT4 since Thursday, May 19, 2022 and the camera started to freeze on Tuesday, May 24 and again the next day. I have to remove the battery to turn it off, because no key reacts, not even the ON/OFF key, the screen always remains frozen.  I have the latest update, the bluetooth is not associated with my smartphone, I have no Flash whatsoever connected with. just the Fuji 18-55mm lens. Where does this problem come from? If you have ever heard of it, any solutions? thank you very much   
×
×
  • Create New...