Jump to content
Sign in to follow this  
Megan A

Can anyone help with this issue with a X-A20?`

Recommended Posts

Advertisement (gone after registration)

I recently purchased an X-A20 second hand. It is in great condition but I am having difficulty settings it up. The screen is white and blurry, I can see movement when waving my hand in front of it but nothing is clear. It didn't come with a detachable lens so I am concerned that is what is causing this. Does it need a derachable lens to work? Does anyone have any answers? The manual wasn't very helpful. Thanks in advance.

Share this post


Link to post
Share on other sites

Yes it needs a lens to "work" in the way you expect. The menus and playback mode should still show as normal on the screen (press the menu button or the play icon) to confirm the screen works. You won't be able to take proper photos without a lens. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...