Jump to content
Nicolas R

I lost my XT4 power Brick (AC-5VJ) Now dual charger takes an eternity

Recommended Posts

Advertisement (gone after registration)

Hey guys, my XT4 power brick and cable got lost or stolen, I own the dual power charger and I was happy with it because it charges both bateries at the same time and very quickly. After I lost the brick and cable I used my smartphone fast charger but now it takes an eternity to fully charge (probably 7 hours) and also it cannot charge 2 bateries at the same time. I want to know if there is any option to buy the original Fujifilm power brick (AC-5VJ) or if there is another option! I find it ridiculous that buying the dual charger doesnt come with another brick and cable (70 dollars!) and also that I cannot buy that brick. Can you guys give me a suggestion? 

 

Actually I connected a 13inch Macbook Pro charger and it looks like its working, but I dont want to carry that with me just to charge bateries and also I dont want to pay that much to replace something so simple as a f...ing power brick! Any ideas? 

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Posts

    • Thanks Andreas! This is a great solution! I ll let a friend print it. Maybe there was a piece of rubber in that spot and it fell out?   Grüße Dirk
    • It might be quite subjective to tell yes or no. I have no problem to use 16-55mm on my X-E2 just use shoulder strap instead of wrist one.
    • Hey again, I just took matters into my own hands and found a great and simple fix. Looking at videos online I see that there's no spring in that latch, instead it seems to hold on by friction. I also took it off the grip to check if there's anything I'm missing (4 screws to take off cap, 1 screw to take off the latch). There's really no space/design for a spring mechanism (see photos). However I realized that underneath the latch there's a bigger recessed pocket. For a quick test I took some p
    • I fixed it with a piece of tape. I guess I ll have to talk to Fuji customer service and ask for a replacement.
    • Hey, I just made this account just to add that I also have the same problem with mine. I never saw a spring or something that sort fly off. In fact I don't even see where one could be located on this tiny latch. How can we repair this since it's irritating handling the grip this way. The sound alone this flappy little latch makes is so annoying.
×
×
  • Create New...