Jump to content
Les White

16-55 vs 18-135 and 55-200

Recommended Posts

Advertisement (gone after registration)

I have the following fuji zooms--10-24, 18-135, 55-200, 50-140 and 100-400 plus a few good primes--I am thinking about selling the 18-135 and 55-200 and getting the 16-55 2.8 since I have the midranges pretty well covered--I would welcome opinions of what I am thinking about

Share this post


Link to post
Share on other sites

Apart from the generic comment that "this depends on what you're shooting" it makes sense to me. I already wondered about the huge overlap in the area beyond 50 mm. The 16-55 is a great lens and as you're used to the 18-135 you won't be struck by it's size and weight. Note that on the wider end (16 mm) the lens has much more distortion and corner softness as the 10-24, so I would definitely keep that, unless you have the 12 or 14 mm primes. On the long end (35 and above) it is a very good lens for portraits. The f2.8 creates a nice focus transition and good quality of bokeh for a zoom lens. Dustin Abbott on Youtube has made a very good balanced review of the 16-55.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Posts

    • Thanks, Olaf. I hope to add to the information flow.
    • When using af, if you zoom in and use it, the camera suddenly stops working. This phrase pops up. 'Check the battery'. However, I have four batteries, but the same phenomenon occurs even if I try to use them while changing. I think it may be a problem with lens production, but have other people ever experienced this??? I live in Paraguay, so I don't have a Fujifilm AS center. I'm looking for a solution.
    • Hello folks, Did anyone else have a hard time registering their X-T4?  I am trying and it won’t accept my X-T4 model number. I can’t get past that part of the registration process. Your help is appreciated.
    • With stills, I had write errors when shooting panorama, CH, CL, long exposure etc and using a slower card. Had reported to Fuji here and as expected the issue was never heard of by them in spite of sending them links to the issues. But they were very helpful in loaning a camera, a faster card and they took my card to try on their camera. It was concluded by Fuji that the card was slow. And the truth is, I switched to a faster card and haven't seen the issue after that.  Also, I never delete
    • Well...this is embarrassing, but maybe helpful for anyone else out there who runs into this - if you change your connection settings to "USB Fixed" you will get the symptoms above. Switch it to "USB Auto" and you should be fine. Basically, while troubleshooting for Webcam usage I switched it and didn't think about the ramifications of leaving it that way. Whoops!  
×
×
  • Create New...