Jump to content

Design disaster: battery cover blocked by quick release plate


Psetel
 Share

Recommended Posts

Advertisement (gone after registration)

I have a serious criticism of the X-T4 design: my Gitzo Traveler quick release plate - the smallest they make - blocks the battery door from opening fully while attached to the camera. The hinge for the door is too close to the tripod//quick release hole and the plate overlaps the hinge just enough to block it from fully opening.

The result is that I cannot remove or change my battery without removing the camera from the tripod and the quick release plate from the camera. What a pain!

Does anyone know of a Gitzo tripod head system compatible with the Traveler model tripod and that has a narrower plate where this won't be a problem? 

Thanks!

Link to post
Share on other sites

Get an Arca-swiss compatible head and go to a proper fitted plate or L-bracket. Gitzo does make some Arca-Swiss compatible heads, or you can go to a better quality head like an RRS or Acratech for similar cost.

Nobody designs for those old plate systems anymore and small cameras have always had issues with most plates, one reason why Fuji sold Acra-Swiss compatible grip/plates for their kit from day 1 of the system.

Edited by mawz
Link to post
Share on other sites

  • 10 months later...
  • 2 weeks later...
On 6/20/2021 at 4:16 PM, ascotjim said:

Same issue. I will grind/cut one end of the plate to shorten it.

That is the cheapest solution and works well. I did that with a Manfrotto QR plate. A more elegant but pricier solution would be to exchange the QR plate base (if possible, look for a screw where the base is attached to the ballhead) for an Arca Swiss baseplate and QR plate.

Link to post
Share on other sites

On 8/19/2020 at 12:57 PM, Psetel said:

I have a serious criticism of the X-T4 design: my Gitzo Traveler quick release plate - the smallest they make - blocks the battery door from opening fully while attached to the camera. The hinge for the door is too close to the tripod//quick release hole and the plate overlaps the hinge just enough to block it from fully opening.

The result is that I cannot remove or change my battery without removing the camera from the tripod and the quick release plate from the camera. What a pain!

Does anyone know of a Gitzo tripod head system compatible with the Traveler model tripod and that has a narrower plate where this won't be a problem? 

Thanks!

I'm confused...is your criticism of the X-T4 or of your Gitzo plate? Where would you have designed the battery door? Or, how would you have designed the Gitzo plate? BTW, my KES L-bracket designed for the X-T4 doesn't block anything so maybe you should check that out.

Link to post
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Similar Content

    • By Gibby
      I'm shooting video with X-T4 on a gimbal, in continuous mode with face detect on.  If I try to change the focus point using the rear touch screen (pressing top right corner of screen until it gets to "AF", and then click on the desired focus point on the screen...it will refocus on that area, but only once.  As if it was switched to single focus mode.  The manual however, seems to indicate that the camera should remain in continuous focus mode and track that subject, which it doesn't.   I would like be able to click on a point using the rear screen and have the camera track in continuous focus.  Is this even possible?  Not clear in the manual.  tks.
    • By Gibby
      For stills, I'm using backbutton focus.  And I'm able to select the focus point and track it in continuous focus.  Works great.  But in video mode, I can't find a way to track an object - only a face using face detect.  The rear touch screen doesn't seem to work this way.  When I select a point, it behaves as single focus, even when the camera is set to continuous focus.  Also, I'm often using the camera on a gimbal and need to rely on the rear screen for setting the focus point.  To date, I've mainly had to use the X-T4 in manual mode for video which is disappointing.  Am I missing something?
    • By Théotim
      Hi all !
      After updating via app (1.23) my brand new x-t4 (work like a charm with 1.22 firmware) the EVF doesn't work at all now and if i try to switch to the EVF view every thing goes black and the camera get stuck like that forever... Even if i try to reboot it, the only option is to plug out/plug in the battery. Impossible to go back to the previous firmware (what a shame on a 2000€ camera). I'm very frustrated my camera is unusable... I update again the firmware with the classic SD option, the process finish the update without a problem but the problem persist cannot do anything with it now. If the camera go sleep... Stucked. If the eye sensor is activated for the EVF... Stucked. If i try to shutdown the camera... Stucked. 
      Thank you in advance.
      Best regard.
    • By R3D
      Hi All,

      Hope that some encountered that problem before and can help.
      I get my X-T4 a few weeks ago with FW 1.17 and it seemed to work correctly but just for the sake of having most up-to-date version I updated to 1.22). 
      After the update my fav view mode ([EYE SENSOR] + [LCD IMAGE DISP.]) is corrupted. It essentially keeps the LCD on whenever eye is away from EVF.
      Image preview is set 1.5 sec and is displayed correctly only on LCD screen. I set the LCD do info screen but it's not really how I'd like to have it working. 
      I was hoping that 1.23 will fix it but unfortunately no change after yesterday's release. 
      Thank you in advance! 
      R. 
       
    • By ccguy
      I'm trying to shoot with flash using a Godox 2.4GHz pair & strobe lights I've successfully used before; however, my only options in my flash menu settings are Manual & OFF. The button on the transmitter works with the receiver, but trying to use flash with the X-T4 has been unsuccessful. Are there any other settings that need to be enabled so it recognizes TTL/my hot shoe mount? 
  • Posts

    • Thank you for your suggestion, but 70 is too tele for me, I did some shots regularly at 50, 55, 60 on my 16-80.
    • When considering the 55-200 also have a look at the 70-300. There's not much difference between f4.8 and f5.6 at the long end and the 70-300 is certainly a faster focusing lens. I'd buy the 55-200 only when it is a great second-hand deal. There's only €100 difference between the two lenses when purchased new. In that case I'd go for the 70-300, but that's just me... 😉 Best Fujifilm Telephoto Zoom Lens 2021 | Photography Blog
    • Thank you! This is great news. Fujinon XF 55-200mm f3.5-4.8 R LM OIS has got nice price, and its aperture in the range of 55-80mm is a little faster than on Fujinon XF 16-80mm f4 R OIS WR that I own, but at 200mm it's f4.8 which I can't tell is usable. I bought 16-80 for indoor sports but also for general purposes like landscape and architecture to complement my 35mm f1.4. For indoor sports, I used it in the range of 50-80mm so far, and I needed some more zoom, but I also know that at some other gyms that I've been before even the 35mm was fine when I could place myself near the court. Not sure if 55-200 is ideal solution for sports either, but it's much cheaper and lighter than 50-140. Heck I think even f2.8 is too small aperture for indoor sports. If I don't go for 50-140, I would most likely go for 55-200.
    • The push function on the rear-dials of the 'earlier' X cameras is quite prone to defects. I believe it was solved in the X-H1 and the X-T3 thereafter, but X-E3's have the earlier internal design. The push function could 'stick' in one function or between functions causing the rotate function not to work properly. If that happens, internal cleaning or replacing is the only option. Something that (most of) you can't do yourself.
×
×
  • Create New...