Jump to content
Rainman

Yongnuo Flash and Mount Adapter

Recommended Posts

Advertisement (gone after registration)

Hi,

I am an enthusiast, not a photographer. I usually shoot for my family, vacations and occasional 'everything'.

I used a Canon setup for last 5 years and recently I sold my dslr. Now I'm planning to enter the Fuji kingdom but few things are holding me up.

I already possess a couple of EF & EF-S lenses and a Yongnuo YN 568 EX II (e-ttl for Canon). I'm a thrifty buyer and looking for ways if I could fit these in fuji ecosystem rather than investing heavily again.

1. What mount adapter (if there's any) I can use for these EF/S lenses to work smoothly (auto focus and auto aperture control etc) with Fuji camera other than expensive options like Fringer?

2. Can I use my existing Yongnuo 568 EX II flash on the hotshoe of a Fuji body?

This would help me greatly to solidify my decision about jumping ship for the mind-blowing X-T200 (for my requirement & budget at least). Otherwise I'll just have to buy a Canon M50.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By huck222
      Hi all, does anyone have experience with a K&F adapter and the Canon TSE lens? I understand i cannot set the aperture with the Fuji camera. Now: Some say a canon lens will default to open aperture. While K&F says, it will stop down fully, (which i can't imagine).
      Some say, set the aperture on a Canon body, then take the lens off (probably while holding the shut-aperture-button??).
      Can anyone tell if and how it works? Thanks! I mean, that TSE 17 mm is a wonderful piece of glass and all 😃
    • By arch_202
      This month I decided to make an investment in a Yongnuo flash system based on high praise from this forum and others. I have 2 YN560 IV flashes, and a YN560-tx trigger, all in the cannon version and in use on my xt-1.
       
      Flashes fire fine while mounted directly to the hot shoe, and connect and can be fired from the 560-tx while mounted to my xt-1. But the flashes will only fire once from the tx. I'll fire the shutter and the tx will pop both connected flashes, wait a few seconds (adjust the model, the lights, ect), and then try and fire a second shot, but the flashes won't pop. The blue LED lights up fine on both flashes, as if the tx is still connected appropriately. They will only fire again once I adjust a power/zoom/group setting on the tx trigger. I've gotten into the habit of just bumping the power up then down on the tx before each shot, just to get the flashes to fire. But this poses a problem when I need to take multiple shots quickly, or if (as is the case when I have no model...) i'm taking self-portraits and am operating from the fuji camera remote app. 
       
      I then tried operating the flashes in trx mode, firing with one flash on the camera and one off. Same thing. The flashes will fire once from camera release no problem, but will not fire again until I adjust a setting on either flash. Optical slave mode fires consecutive flashes no problem, and the pilot button works consecutively no problem as well. My suspicion is that they're wating for a half-press wake up signal from the tx before each flash release, but since I'm operating from a fuji camera, the wake-up signal on half-press is not supported, and it doesn't send it. 
       
      I've scoured the forums and tutorials around the web to see if i'm doing something wrong. I've set what I think are the appropriate settings (same channel and groups on all connected flashes/trigger, flashes in rx mode, single flash, camera not in silent mode, manual shutter, single shot, live-view off). I even ordered a second trigger, but when that arrived yesterday and operated exactly the same way, I reached a particular level of despair. I'm considering returning it all and abandoning off-camera flashes for the time being.
       
      Any and all help is welcome and appreciated. Thanks!
    • By LightShaper
      What am I doing wrong? X-E1, E2 & Pro1 hot shoe's are not triggering a Yongnuo RF-603C II. A flash mounted on second 603 will fire when the manual (test) button on the camera 603 is pressed, so I conclude the Yongnuo's are working properly, but that the camera 603 isn't receiving a trigger signal from the camera. Cameras set to S mode (single shot) and silent mode is off. Tried in both auto and manual. I've read that X bodies WILL trigger the Yongnuo so I'm puzzled. Thanks for any suggestions.
    • By oldfashioned1536
      I got rid of all my canon gear except for the EFS 10-18mm lens for which I bought the fotodiox adapter on amazon. For some reason, the lens does focus to infinity at 10mm. It only focuses if I get very close to an object (at 10mm). At 18mm however, it focuses to infinity just fine. Any ideas why this is?
       
      Camera setting:
       
      Manual Mode
      Canon lens is also on manual focus
      I input the focal length of 10mm in the menu under lens mount adapter setting
  • Posts

×
×
  • Create New...