Jump to content
  • Posts

    • I haven't experienced any issues as of yet.
    • I've ordered one but it's still on backorder. 🙁
    • The X-S10 is my first Fuji camera, for me it makes photography more fun while getting professional results. I've been a Pentax user since the 1970's but I'm very happy with the decision to purchase Fuji over other camera brands.
    • Hey all, bought a used X-T3 body for $850 shipped over a Fuji buy/sell group on Facebook, all checks out and the seller was very professional. Camera shipped with original box and in essentially mint condition cosmetically, except for when testing it this afternoon I noticed that the direction arrow buttons (around the Menu/OK button) were "sticky," or felt like maybe there was some debris inside them. They were clicking reliably, but some clicks would feel soft and then others would feel crunchy/hard. My X-T2 doesn't have this issue, so I know what the d-pad is supposed to feel like. Strangely, if I sort of rapidly click each of the buttons maybe 10 times each, the issue completely goes away and then an hour or so later if I pick up the camera again it's back. It's nothing dealbreaking, and doesn't take away functionally from the camera, but I'm trying to see what kind of avenues I might be able to take to address it. Has anyone else had this issue? How did you resolve it? Is it a known problem, and may it get worse over time? Google didn't turn up any search results for the D-pad specifically being "sticky" feeling, only shutter buttons and joysticks.
×
×
  • Create New...