Jump to content
GaryZ

Problem with X-PRO2 and lens adapters...

Recommended Posts

Advertisement (gone after registration)

Hello all,

I am new to this forum and to digital photography. I just bought a new X-PRO2 and I am just starting to learn how to use the camera but one of the reasons I chose this one is so I could use my old Nikkor and Leica lenses on it. Last night I tried one of my Nikkor with the adapter I bought from B&H and every thing worked fine except the shutter I was not able to snap a picture. Is there a special setting I need to use? Has anyone else had this problem?

Thanks in advance.

Share this post


Link to post
Share on other sites
Posted (edited)

I got my XPro2 to work with my Nikon F manual lenses. Did have to hunt down that "Shoot without Lens" setting! Generally I find Fuji's menu structure to be less than comfortable for me. But then I've been Nikon since school, 1960-ish.

Backyard Bluebirds with Nikkor f8/500mm mirror lens.

Edited by Chucktin
Added picture

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Posts

    • Search your manual for "PRE-AF" option. If ON camera should focus without pressing release botton.
    • Thanks, Willtoride. It's beginning to make sense to me now. I guess I was really stressing the CPU.
    • Just got the new X-S10. I don't think you have a forum for the X-s10 yet. Hopefully this is the right place to post. I'm confused about how autofocus works. I'm sure it is similar on all X models. Before I bought, I watched tons of videos on youtube about the X-S10 and when they tested the autofocus, they would walk away or towards the camera so you could see the focus adjust. Now that I got the camera, I'm baffled. (1) AutoFocus doesn't seem to happen automatically but you have t
    • I have only been able to get the XWebcam and XWebcam2 to work on my Macbook Pro )mid 2012, Catalina) with QuickTime Player Capture video without controls of the XWebcam software and with XWebcam/XWebcam2.  I have been able to get it to work with Zoom only. Not FaceTime, not Skype, not Google Meeting. My old Logitech Webcam work with everything also.
    • 4k 60fps 400Mbps means you're using the H265 codec. It's very cpu/gpu intensive. My 2016 MBP struggles to play H265 smoothly but my main editing machine plays them back fine, so this could be the issue you're seeing. Try H264, which will limit you to 200Mbps or maybe create proxies.
×
×
  • Create New...