Jump to content
Ken Long

Webcam X issues with my X-T3

Recommended Posts

Advertisement (gone after registration)

Hi

Not sure if I'm in the right place for this, if not please point me in the right direction.

I want to try out the Webcam X software to use my XT-3 as a webcam. I have downloaded and run the installer but I keep getting the same issue. I get a pop up message that reads "Module C:\Program Files (x86)\Fujifilm X Webcam\fujivcam.dll failed to register. HResult -2140024770. Contact your support personnel." I then have the options to exit installation, try again (same box pops up), or continue (tells me the software is succesfully installled). I have uninstalled and reinstalled. I have switched everything off and back on again!

When I set up my X-T3 as per Fuji's instructions it doesn't show up in the camera drop down box in Zoom, so I'm assuming that this error message means something! I have double checked the necessary camera settings and they are as required. Googling "fujivcam.dll failed to register" hasn't brought up anything helpful.

Any ideas? It's a Windows laptop, running fully updated Windows 10 if that helps? As I'm typing this it occurs to me that do I need to have the firmware on the camera bang up to date?

Share this post


Link to post
Share on other sites
Posted (edited)

I have the same exact problem. (HRESULT -2147024770), and the same fujivcam.dll. I've also tried it on two different Win10 systems as well.

Quote

 

Update 6/15 :

I tried it on a 3rd Win 10 system and it just worked (Hi end HP laptop), and to rub salt on the wound (need it to work on my desktop system), it's pretty freakin' sweet when it does actually work.

The other systems that didn't work are a cheap Acer Win 10 S laptop updated to a regular Win 10 Home system, and a custom built desktop system with an old Win 7 updated to Win 10. I had read somewhere that this Fujifilm Webcam software won't work with custom installs, but that means it should have worked with the cheap Acer laptop. Such a strange issue.

6/16:  HP latop Win 10 OS build 1903. Acer and desktop are 1909... maybe that's it, what's everyone's build?

9/8/20: Nope. I got my other system back to a 1903 build, not it. 

 

Edited by ScribbleShot

Share this post


Link to post
Share on other sites

Hi All, yes I am facing the same issues, According to a similar error in another software to be installed in Win XP, this indidcates that Windows somehow inhibits the neccessary file to be registered in its miracolous .dll djungle. As a result, the driver probably never gets really installed, hence it won´t show up in any of your preferred video apps.

http://help.cognex.com/Content/KB_Topics/VisionPro/Software/2822.htm

As of now, I do not have a resulotion for this challenge, as the path described in the link atop does not work on my Win X installation.
BUt I keep my eyes wide open, best if we inform Fujifilm about it.

Share this post


Link to post
Share on other sites

Same here. Used Apple bootcamp to create a windows partition, vanilla install of Windows 10 Pro and get the same problem. Reinstalled Windows 10 -- tried Home edition this time -- and same problem. This is a "clean slate" install, with nothing else on the system.

Share this post


Link to post
Share on other sites

Have you tried right-clicking and running/installing as Administrator? Sometimes certain file locations are restricted by Windows as a normal user.

Share this post


Link to post
Share on other sites

dwha, this did not work for me, same error. I tried it with the link and file you provided, and with Microsoft's English version website (tried both VC 2017 & 2019 there). *edit [also restarted after each install and of course uninstalled before trying the next one]

You seemed sure that would work, are you aware of something specific within that installer that you think is the root issue?

Edited by ScribbleShot

Share this post


Link to post
Share on other sites
4 hours ago, dwha said:

You need to install VC redist package 2017 x86. It'll solve the problem.

Go to https://support.microsoft.com/ko-kr/help/2977003/the-latest-supported-visual-c-downloads
There, you can download x86 version of redistributable packages. 

Good luck!

Nope, that is not it. That was already installed, and Windows 10 will stop you from trying to install it again.

 

Share this post


Link to post
Share on other sites

I'm due for a system wipe, gonna try Windows 10 1903 build (the computer I have that this webcam tool actually worked on), as I'm currently rocking 1909. We'll see. Will report back.

**Update: Nope, after a full day of trying to get my system back to Windows 10 1903 (had to go back to 1511, the only old win10 image I had, cause MS doesn't hand out 1903 any longer, and update my way to 1903, ), and I can say that's not it.

Edited by ScribbleShot

Share this post


Link to post
Share on other sites

Just an FYI If anyone still has this problem.

I have experienced the "HRESULT -2147024770"  error on a modern ASUS ultrabook with a new SDD installed but conversely, had a first-time successful install on another upgraded PC.

I was able to solve the problem on the Asus by uninstalling the 'broken' Fuji software then installing the latest MS Visual C libraries from: https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads, then reinstalling the Fuji s/w. The error disappeared and the camera was immediately recognised in both Zoom and Google Meet.

However I have a third PC, an old and much-updated Lenovo running the latest win10, that displays no errors when installing the software, but refuses to send the camera feed to any applications (i.e. the camera shows as being connected to the PC, but doesn't appear as a selectable device in Zoom or Meet).  The Visual C trick hasn't worked on that PC.

 .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Posts

    • Thanks so much! My Q button was usable the day I bought my new Xt4 then whilst I was playing with the settings I disabled it somehow and didn't know what I'd done. You just made my day since I hadn't been able to work out how to get it back. I had noticed the lock on also but hadn't looked thru the manual yet to see what it was. 
    • Alguien me puede explicar como activar la sincronizacion en 2a cortina en mi X-T2? A pesar de dejar activado el rear de 2a cortina, cuando disparo con 1/1000 me sale como si estuviera haciendo la foto en sincro con la 1a cortina . Tengo un Godox 860II tengo que activar algo ahi?
    • Hello guest! Please register or sign in to view the hidden content. X-E2 + 27f2.8  
    • Thank you for your insights. I think even without my menu it just starts "from scratch" in the menus, which is especially annoying if you change the buried custom display settings. Another minor problem is the display of the highest ISO if ISO is in auto mode in the display. I find it distracting and not of much value, instead I would like to see a real time update of the chosen iso of the current lighting situation. If I half press the shutter it seems to work this way but it doesnt seem v
    • My R2  (Fuji)transmitter no longer displays ttl as a Mode choice  on my Fuji Xt2, x100f and x100v. I only see M or -- as options when pushing the mode button. My older R2 Pro model does work in all three modes, M, ttl and --.    Problem solved.  The newer R2Mark II transmitter has a Shutter option with a choice of either Curtain or Leaf.  When Leaf is selected (appropriate for x100) then the only mode choices are M/--. If you select Curtain then the choice become M/TTL/-- .  If you select C
×
×
  • Create New...