Jump to content

Recommended Posts

Advertisement (gone after registration)

New XPro3 owner here. Absolutely love this camera, but wondering if I have some random build quality issues:

* Is the MCS lever looser/louder vs the XT3? Mine is rather loose. It kind of bends a bit when I toggle between the S, C, M modes. Almost like it's going to pop off the body. Makes a loud clicking nose when I switch modes vs the much quieter lever on the XT3. The XT3 lever is also much tighter.. feels well connected to the camera.

* There is a random green-ish ink mark on top of the on/off switch. Kind of looks like green pen ink and doesn't come off.

Most likely sending back to B&H for a replacement. I've used the XT3 and XE3 a lot... and never had any issues with those cameras.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Posts

    • @maplineThanks for the answer,  I think i'm gonna opt for a wifi card instead, as it suits more my needs, (reducing transfer times and  timelapse real-time rendering). The hdmi thing would be ok if i wanted to capture video material, but i mainly do long exp/timelapses   Cheers
    • 1000 is a curious number - if you are using F-Log the minimum ISO is 640 - but haven't heard of any setting that restricts to 1000
    • I recently purchased a used Fujifilm X70 and there is something going on that I don't understand. Some times when I take photos the image comes up heavily distorted. It only seems to happen when I take a photo of a moving object, even at 1/1000 shutter speed and I'm not moving. I can understand some blur if my shutter speed is not fast enough, but this distortion? It only happens with moving objects, using manual and auto focus. I attached some images. The images are taken at 1/1000  F8. What co
    • I do remember reading from the website, and from Ken Wheeler that you need to use an SD card for updating.  Ken Wheeler highly recommends using SanDisk 300Mb/s cards.  Just relaying information.
    • Yeah, that sounds bad.  Check my post.  There is one dude, on the forum, and Ken Wheeler, who is trying to be helpful, to which I am very thankful.  Usually I try to wait at least 6 months to 1 year before buying.  Risky being a consumer tester for a new product.  In my case, I too had issues.  The "What Have You Done?" post.  Took it back the next day, but am willing to be as helpful as I can be.  If I don't have the answer, I'll ask around.  I'll definitely remain active in the forums, as I re
×
×
  • Create New...