Jump to content
Fenderguy1234

XT-20 not reading SD Card? "No memory card inserted"

Recommended Posts

Advertisement (gone after registration)

I just received this camera in black for Christmas.  I formatted my SD Card, which is a Sandisk 128 gb XC1 card.  My camera tells me no memory card is inserted.  The menu option to Format is grayed out.  I tried formatting the card on my computer, which I could do in both NTFS and exFAT formats.  Still, the camera can't read my card.   Do you guys think this is a problem with the camera?  Or should i buy a new card?

Share this post


Link to post
Share on other sites

You probably have a SanDisk Ultra SDXC UHS-I card - they are slow but should be visible to the camera.

You said you formatted the card and then tried using a computer - does that mean that the camera initially formatted the card?

Its best to format the card in the camera (the X-T20 would format the card as exFAT).

The fact that your computer would read the card implies a camera rather than card problem. Have you checked inside the card compartment for any obvious problem or dirt?

How easy is it to take the camera back? If that's difficult because its a present you could try a new card first before getting Fuji to check the camera (something like the SanDisk Extreme Pro UHS-I cards are well regarded and relatively inexpensive for the smaller cards).

Share this post


Link to post
Share on other sites

Advertisement (gone after registration)

This SD card was originally formatted in a Pentax camera, but I since formatted it in my computer. The plan was to format it in the XT20 before I began shooting. 

 

I will try cleaning the slot with alcohol. 

 

This isn't a card error, but rather just a "memory card not found" message. 

Share this post


Link to post
Share on other sites
1 hour ago, Fenderguy1234 said:

Well this is quite the relief....

 

I found an old 2gb Kingston sd card laying around the house.  It works!

 

 

Good news - I'd still recommend a faster card such as the SanDisk Extreme Pro - might not make an enormous difference but will flush the buffer faster if you do any continuous bursts (and will copy from card to computer faster).

Share this post


Link to post
Share on other sites

I also had this issue with my X-T2 saying:

"No memory card - Insert a new card"

This is the first time I have encountered this with my camera. I am using a micro SanDisk Extreme Pro 32GB V30. My MacBook Pro was able to read this card through an external card reader but my camera was not able to.

I have tried 2 other Sandisk cards and they work just fine. 

Please help!!!

Thanks.

Edited by mrbasshole
additional info

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...