Jump to content

Search the Community

Showing results for tags 'sticking aperture'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Fuji X Forum

  • Fuji X News & Rumors
    • Fuji X Rumors & News
    • General Discussion
    • Newbie / Self Introduction
  • Fuji X System
    • Fuji X-H1 / Fuji X-H2s
    • Fuji X-T4
    • Fuji X-S10
    • Fuji X-T3 / Fuji X-T30
    • Fuji X-T2 / Fuji X-T20
    • Fuji X-T1 / Fuji X-T10
    • Fuji X-T100 / Fuji X-T200
    • Fuji X-Pro 1 / Fuji X-Pro 2 / Fuji X-Pro 3
    • Fuji X-E3 / Fuji X-E1 / Fuji X-E2 / Fuji X-E2s
    • Fuji X-M1 / Fuji X-A1 / Fuji X-A3 / Fuji X-A5 / Fuji X-A20
    • Fuji X Lenses
    • Adapting lenses to Fuji X
  • Fuji GFX Forum
    • Fuji GFX 100S
    • Fuji GFX 100R
    • Fuji GFX 50S
    • Fuji GFX 50R
    • Fuji GFX Lenses
  • Other Fuji X Cameras
    • Fuji X100 / X100S / X100T / X100F / X100V / Fuji X70
    • Fuji X10 / X20 / X30 / XF1 / XQ1 / XQ2
  • Fuji X Post Processing
    • RAW conversion Fuji X-Trans Sensor
  • Fuji X Video
    • Fuji X Video
  • Fuji X Accessories
    • Flash Photography with Fuji X
    • Bags, Half Cases & Straps for Fuji X
    • Other Fuji X Accessories
  • Fuji X Photo Forum
    • People
    • Street Photography
    • Nature & Wildlife
    • Landscape & Travel
    • Sports
    • Misc

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hello, I have a 2 year old X100F that has a problem with the aperture blades being stuck. It appears to be suck at about f2.8-4. I bought the camera new in the US about 2 years ago, I currently live in Asia and need advice on having it repaired. I contacted the place of purchase but they can't help because its beyond warranty. I contacted the Fujifilm repair USA office but they told me to contact the Fujifilm Malaysia office. Fuji Malaysia said the US office is wrong that I should contact an office closer to my area. They did however suggest resetting the camera preferences but this was no help. My last resort is to contact the Fujifilm Japan office but it is closed indefinitely due to quarantine. So my only solution may be to try and fix it myself. Has anyone here experienced their aperture blades stuck in their X100F? Has anyone been able to take the camera apart and fix it themselves? I'm extremely disappointed with Fuji and that this happened in less than 2 years of owning this camera and now no reasonable solution to fix it. I've also read that the repair for this problem is quite expensive. It would be nice to know if anyone has had similar issues and any luck with repairs. Until now I loved Fuji and this camera however I can't be more disappointed. Thanks
×
×
  • Create New...