Jump to content

Reactivestills

Members
  • Content Count

    36
  • Joined

  • Last visited

  • Days Won

    2

Reactivestills last won the day on September 14 2017

Reactivestills had the most liked content!

About Reactivestills

  • Rank
    Advanced Member

Profile Information

  • Gender
    Male
  • Location
    Dublin, Ireland
  • Interests
    Korean Film, Photography, Graphic Design, Exercising, Reading, Aquatics
  1. It seems the Lcd tint has not been rectified in different bodies.I really thought that Fuji would have seen the amount of complaints with the X-T2 and worked on a resolution.Heres 2 X-T30’s I bought within a month of each other side by side.Totally reset with latest FW and setup from the start and still an lcd yellow tint is present.Warranty exchange needed - even after adjusting lcd color and brightness etc. The EVF and LCD are showing same issue.Ridiculous and a complete pain in the ass.Brought back the X-T30 today and tried 3 in store - all exhibited same issue in varying degrees of yellow tint.How can they not calibrate the system to be neutral throughout!!!I tried to par up two of the test units to take a pair that were exactly the same and they were all different !I was offered a refund but opted to try more as I shop regularly at the store. They have contacted Fujifilmto order others from possibly another batch to test.This is an an absolute joke in my opinion. Considering the cost of the cameras they have as a flagship have had issues they should have been on this issue from the get go. I have had T1, E2s and XM1 bodies and all were perfectly calibrated. It good at all
  2. Brought back the X-T30 today and tried 3 in store - all exhibited same issue in varying degrees of yellow tint. I was offered a refund but opted to try more as I shop regularly at the store. They have contacted Fujifilm to order others from possibly another batch to test. Absolute joke in my opinion. My X-E2s, X-T1 and evening X-M1 do t exhibit this problem. I did order a 2nd X-E2s when B&H had a sale and it had the issue and had to be sent back also a few years back. I’ll keep you posted.
  3. It seems the Lcd tint has not been rectified in different bodies. i really thought that Fuji would have seen the amount of complaints and worked on a resolution. Heres 2 X-T30’s I bought within a month of each other side by side. Totally reset and setup and still an lcd yellow tint is present. Warranty exchange needed - even after adjusting lcd color and brightness etc. The EVF and LCD are showing same issue. Ridiculous and a complete pain in the ass.
  4. X-Pro 2 all the way. After selling my T1 and buying the X-E2s, the rangefinder is much nicer to use. If the rubber comes off the X-T2 a lot of people will be annoyed again. Disaster of a situation.
  5. X-T1 - XC55-200mm - Howth Harbour - Dublin
  6. X-T1 - 18-55mm - Park Walk - Dublin
  7. X-T1 - 18-55 - Sally Gap - Wicklow
  8. X-T1 - XF18-55 - Poulanass waterfall - Wicklow Ireland
  9. X-T1 XF35mm - Poulanass Waterfall - Wicklow,Ireland
  10. Does anyone find this is loose in the fuji mount - I tried two different copies on my X-T1 and it was moving far too much in the mount. I am eager to find out if its different on the X-E2. Anyone have this issue??
  11. I sold my X-T1 because of this bullshit and bought an X-E2s. I have had many other bodies without this stupid problem. Hopefully they take this on board and sort it out. As others have said the rubber is too far over the lip of the metal.
×
×
  • Create New...